Go Down

Topic: Absturz des ARDUINO beim Schalten von Relais an angeschlossener 8-fach Karte (Read 1 time) previous topic - next topic

herbert-f

Hallo,

ich hoffe ihr könnt mir helfen  :smiley-roll-blue:

Mein Arduino MEGA 2560 stürzt "manchmal" ab wenn ich ein Relais an der angeschlossenen Karte (8-fach (blaue) aus der Bucht) schalten möchte. Ich habe schon alle induktiven Lasten etc. abgeklemmt, so dass ich "zum Test" mittlerweile nur noch eine Widerstandsbrücke umschalte und somit am Relais selbst keine Last anliegt.
Trotzdem stürzt der MEGA hierbei manchmal ab. Ohn dieses Reliasschalten läuft er "unbegrenzt" fehlerfrei durch.

Was kann ich tun?

Eisebaer

hi,

dieses problem gab's schon tausendfach, und die lösung scheint zu sein, solid state relais aus der bucht zu verwenden. das dürfte diese probleme ausmerzen.
natürlich blöd, wenn man das ding halt schon zuhause und bezahlt hat...

gruß stefan

jurs


Was kann ich tun?


Erstmal die Stromversorgung prüfen: Über den 5V Pin vom Arduino darfst Du das Relais-Board nur dann mit Strom mitversorgen, wenn maximal 2 Relais zur selben Zeit geschaltet sind.

Ansonsten braucht das Relais-Board eine eigene 5V Stromversorgung (GND vom Arduino und GND von der Relaisboard-Stromversorgung untereinander verbunden),

herbert-f


hi,
dieses problem gab's schon tausendfach, und die lösung scheint zu sein, solid state relais aus der bucht zu verwenden. das dürfte diese probleme ausmerzen.
natürlich blöd, wenn man das ding halt schon zuhause und bezahlt hat...
gruß stefan


Hallo,
ich habe gedacht, das gabs nur bei induktiven Rückkopplungen -- nun gut, kann mir jemand preisgünstige Solid-STATE-Relais empfehlen (ich möchte 230V-AC Relais bzw. Schütze schalten) ?

Dank im Voraus
herbert

herbert-f



Was kann ich tun?


Ansonsten braucht das Relais-Board eine eigene 5V Stromversorgung (GND vom Arduino und GND von der Relaisboard-Stromversorgung untereinander verbunden),


Ist bei mir so, auch wenn es zum Schluss ein Netzteil ist.



hi,
dieses problem gab's schon tausendfach, und die lösung scheint zu sein, solid state relais aus der bucht zu verwenden. das dürfte diese probleme ausmerzen.
natürlich blöd, wenn man das ding halt schon zuhause und bezahlt hat...
gruß stefan


Hallo,
ich habe gedacht, das gabs nur bei induktiven Rückkopplungen -- nun gut, kann mir jemand preisgünstige Solid-STATE-Relais empfehlen (ich möchte 230V-AC Relais bzw. Schütze schalten) ?

Dank im Voraus
herbert


Wäre so etwas für deinen Einsatz brauchbar? ebay 181156492182
Anfänger, der sich am Mega versucht. (Wegen Pin-Mangel bin ich vom Uno auf den Mega umgestiegen) Aktuelles Projekt: http://mfc-wittgenstein.

maverick1509

Immer wieder das gleiche Thema, und wie eisebaer schon geschrieben hat,
aus eigener Erfahrung kann ich sagen es hilft nur eines: SSR
gruß

herbert-f



Wäre so etwas für deinen Einsatz brauchbar? ebay 181156492182

[/quote]

also der wäre der Traum - werde mir einen holen, verstehe zwar immer noch nicht warum die blauen nicht gehen, es scheint ja sowohl ein Optokopller als auch einen Treiber-Transistor auf dem Relais-Board zu sein, na egal - die 16Euronen soll es mir wert sein

maverick1509

so was:
http://www.ebay.de/itm/SHARP-S202S12-ZIP-4-SIP-Type-SSR-with-Snubber-Circuit-and-/221198955531?pt=Bauteile&hash=item33807c340b

wenn du mit 2A auskommst geht auch dein Vorschlag

herbert-f


so was:
http://www.ebay.de/itm/SHARP-S202S12-ZIP-4-SIP-Type-SSR-with-Snubber-Circuit-and-/221198955531?pt=Bauteile&hash=item33807c340b

wenn du mit 2A auskommst geht auch dein Vorschlag


DANKE EUCH ALLEN !!! Habe mir jetzt so eine 8-fach Karte SSR bestellt!

SCHÖNES WE !!!!!!!!!!!!

michael--g

Hallo Herbert,

hast Du Deine Relaiskarte inzwischen bekommen?
Ich bin an Deinen Erfahrungen interessiert, weil ich zurzeit mit einem ähnlichen Problem und einer "blauen Relais-Karte" nicht weiterkomme.

Grüße

Algorith



jo hatte das Problem auch mal.
sehr doofe Sache.

gibt zwei Möglichkeiten das zu lösen...

erste und beste Soid State Relais verwenden. Die erzeugen quasi null Induktivität.
Wenn wenigen Relais benötigt werden auch nicht grade teuer. ca 10 euro bei ebey.

zweite Möglichkeit ein PC Netzteil verwenden. Für den Arduino und das Relais unterschiedliche Anschlüsse zur Stromversorgung wählen. Das Netzteil hat genügend 12v und 5v Anschlüsse. Und um 100 % sicher zugehen, dass kein Induktivität vom Relais auf den Arduino wirkt, habe ich noch jede Stromversorgung mit einem RC Glied ausgestattet.

danach war alles ok.

ein schlechtes Netzteil gleicht Spannungs- Schwankungen nicht so gut aus.


der Arduino ist bei mir nicht durch das schalten des Relais abgestürzt sondern erst wenn ich an das eingeschaltete Relais meinen 230V AC Verbraucher angeklemmt habe. Wir mit dem Relais eine DC Spannug geschaltet tritt das Problem nicht auf.

Vermute, dass bei der kleinen Baugröße, die AC Spannung die Relais Spulen beeinflusst und der Optokoppler nicht besonders gut ist!


Ich vertraue den dingern auf keinen Fall!! viel leicht um es im Dauergebrauch zu benutzen bis 1A ok,
Man will ja auch nicht mit dem Ding abfackeln. Diese China Relais Module sollen angeblich 10A aushalten...


aber wer z.B eine kleine E Heizung oder der gleichen betreiben will, ist mit einen Industrie Relais oder sogar einem SS Relais besser beraten.

uwefed


Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy