Pages: [1]   Go Down
Author Topic: Absturz des ARDUINO beim Schalten von Relais an angeschlossener 8-fach Karte  (Read 1009 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

ich hoffe ihr könnt mir helfen  smiley-roll-blue

Mein Arduino MEGA 2560 stürzt "manchmal" ab wenn ich ein Relais an der angeschlossenen Karte (8-fach (blaue) aus der Bucht) schalten möchte. Ich habe schon alle induktiven Lasten etc. abgeklemmt, so dass ich "zum Test" mittlerweile nur noch eine Widerstandsbrücke umschalte und somit am Relais selbst keine Last anliegt.
Trotzdem stürzt der MEGA hierbei manchmal ab. Ohn dieses Reliasschalten läuft er "unbegrenzt" fehlerfrei durch.

Was kann ich tun?
Logged

Wien
Offline Offline
Edison Member
*
Karma: 29
Posts: 1957
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi,

dieses problem gab's schon tausendfach, und die lösung scheint zu sein, solid state relais aus der bucht zu verwenden. das dürfte diese probleme ausmerzen.
natürlich blöd, wenn man das ding halt schon zuhause und bezahlt hat...

gruß stefan
Logged

Germany S-H
Offline Offline
Faraday Member
**
Karma: 174
Posts: 3274
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Was kann ich tun?

Erstmal die Stromversorgung prüfen: Über den 5V Pin vom Arduino darfst Du das Relais-Board nur dann mit Strom mitversorgen, wenn maximal 2 Relais zur selben Zeit geschaltet sind.

Ansonsten braucht das Relais-Board eine eigene 5V Stromversorgung (GND vom Arduino und GND von der Relaisboard-Stromversorgung untereinander verbunden),
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi,
dieses problem gab's schon tausendfach, und die lösung scheint zu sein, solid state relais aus der bucht zu verwenden. das dürfte diese probleme ausmerzen.
natürlich blöd, wenn man das ding halt schon zuhause und bezahlt hat...
gruß stefan

Hallo,
ich habe gedacht, das gabs nur bei induktiven Rückkopplungen -- nun gut, kann mir jemand preisgünstige Solid-STATE-Relais empfehlen (ich möchte 230V-AC Relais bzw. Schütze schalten) ?

Dank im Voraus
herbert
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Was kann ich tun?

Ansonsten braucht das Relais-Board eine eigene 5V Stromversorgung (GND vom Arduino und GND von der Relaisboard-Stromversorgung untereinander verbunden),

Ist bei mir so, auch wenn es zum Schluss ein Netzteil ist.
Logged

NRW
Offline Offline
Full Member
***
Karma: 3
Posts: 149
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi,
dieses problem gab's schon tausendfach, und die lösung scheint zu sein, solid state relais aus der bucht zu verwenden. das dürfte diese probleme ausmerzen.
natürlich blöd, wenn man das ding halt schon zuhause und bezahlt hat...
gruß stefan

Hallo,
ich habe gedacht, das gabs nur bei induktiven Rückkopplungen -- nun gut, kann mir jemand preisgünstige Solid-STATE-Relais empfehlen (ich möchte 230V-AC Relais bzw. Schütze schalten) ?

Dank im Voraus
herbert

Wäre so etwas für deinen Einsatz brauchbar? ebay 181156492182
Logged

Anfänger, der sich am Mega versucht. (Wegen Pin-Mangel bin ich vom Uno auf den Mega umgestiegen) Aktuelles Projekt: http://mfc-wittgenstein.

Offline Offline
Sr. Member
****
Karma: 10
Posts: 361
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Immer wieder das gleiche Thema, und wie eisebaer schon geschrieben hat,
aus eigener Erfahrung kann ich sagen es hilft nur eines: SSR
gruß
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset



Wäre so etwas für deinen Einsatz brauchbar? ebay 181156492182

[/quote]

also der wäre der Traum - werde mir einen holen, verstehe zwar immer noch nicht warum die blauen nicht gehen, es scheint ja sowohl ein Optokopller als auch einen Treiber-Transistor auf dem Relais-Board zu sein, na egal - die 16Euronen soll es mir wert sein
Logged

Offline Offline
Sr. Member
****
Karma: 10
Posts: 361
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

so was:
http://www.ebay.de/itm/SHARP-S202S12-ZIP-4-SIP-Type-SSR-with-Snubber-Circuit-and-/221198955531?pt=Bauteile&hash=item33807c340b

wenn du mit 2A auskommst geht auch dein Vorschlag
« Last Edit: July 19, 2013, 05:56:50 am by maverick1509 » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


DANKE EUCH ALLEN !!! Habe mir jetzt so eine 8-fach Karte SSR bestellt!

SCHÖNES WE !!!!!!!!!!!!
Logged

Offline Offline
Jr. Member
**
Karma: 4
Posts: 97
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Herbert,

hast Du Deine Relaiskarte inzwischen bekommen?
Ich bin an Deinen Erfahrungen interessiert, weil ich zurzeit mit einem ähnlichen Problem und einer "blauen Relais-Karte" nicht weiterkomme.

Grüße
Logged

Pages: [1]   Go Up
Jump to: