Go Down

Topic: Attiny 85 with virtual library (Read 1 time) previous topic - next topic


Hey guys, want to ask, can I use virtual.h library with attiny 85 chip ? I tried but it seems not to be working to me.

Anyone tried before ?

Thanks in advance :)


Did you mean virtualwire ?

In that case take a look at this:



Jul 27, 2013, 06:51 am Last Edit: Jul 27, 2013, 07:52 am by camdenbuddy Reason: 1
VirtualWire 1.17 (the latest release http://www.airspayce.com/mikem/arduino/) should work with Attiny85, as far as the revision notes says...

However I still could not get the supplied Transmitter and Receiver code to work though! My setup uses TXC-1 on Attiny85 (Pin 1 connected to Data on TX module) and RXB-1 on Arduino Uno (pin 11 connected to Data on RX module). I uploaded the Transmitter and Receiver codes supplied with VirtualWire, with respective pin assignments. Code compiles and upload without any issues. However, I only see "Setup" on the serial window connected to Arduino. Connected an Oscilloscope to Data pin of RX module, and it does show a continuous burst of signal (Transmitter continuously sends "hello" with 200ms delay). This assures the Tx and Rx modules works fine. However, it looks like the VirtualWire cannot identify the messages. in fact, it seems more like the condition "vw_get_message(buf, &buflen)" never satisfied.


I have tried this library on a ATtiny85


It works realy well both as TX and RX on the tiny

With other librarys I have had some difficulty width the rx part on a t85


I followed exactly as this http://mchr3k.github.io/arduino-libs-manchester/ but still I don't see anything on the RX serial monitor. Can see the burst of signal at RX data pin on Oscilloscope. Need to test more..


Okay, its working at last!!
Actually, I had to follow the steps given at http://mchr3k-arduino.blogspot.com.au/2012/01/wireless-sensor-node-part-2.html very closely (to the letter) to get this working. I tried to find short-cuts in vain.

My setup is pretty much the same, having Attiny85 on the TX end and UNO at the RX end.
Following are the few steps I have done differently, which didn't give me results in the first place. Hope this will help save a bit of anybody's time and frustration.

1) used Tiny AVR programmer (from sparkfun) to program the Attiny85 with the Manchester TX code. Code uploaded without an issue, but the receiver didn't recognize anything comming from the transmitter at all.
2) Used Arduino IDE 1.05 for programming both Attiny85 and UNO

I think, what made this work is the step to program the bootloader into Attiny85 using Arduino IDE 0022. I do not understand why but this one step seems to be the key. I tried to do the same with IDE 1.05 which failed.

Since now I have the results, I can further experiment understanding the fundamental issues which hindered the progress to start with. I do like to use the Tiny AVR programmer to upload the TX code to Attiny85 using latest Arduino IDE (1.05) and use the same IDE to do the receiver on UNO.


Jul 30, 2013, 06:42 pm Last Edit: Jul 30, 2013, 06:44 pm by Erni Reason: 1
I don't understand why it should be necessary to use two IDE versions.

I use this core for the tiny's:


and IDE 1.01 or 1.04, without any problems.

I know that other cores have (or had in the past?) some timing issues.

Go Up