Go Down

Topic: EDIT - Wifi Repeater No Internet Connection (Read 4129 times) previous topic - next topic

jtw11

Jul 22, 2013, 11:37 am Last Edit: Jul 28, 2013, 12:10 pm by jtw11 Reason: 1
Hi all,

First off - i'm sure this probably isn't the right place to post this, as it's completely unrelated to anything Arduino - but wholly related to networking so thought I'd post it here and hope for some answers!

At home I use a wireless repeater to pick up my main wireless signal and broadcast it furthur into the house, being an l-shape with lots of mirrors the signal dosen't go too far by itself. I use an Edimax EW-7416APn - which for the past two years has worked (almost) flawlessly, repeating the signal furthur into the house.

However, I went away for a week and turned the repeater off and it hasn't worked since. The main wi-fi connections works absolutely fine, and one can connect fine to the repeater itself - but with no internet connection.

I can ping both the repeater (192.168.0.50) and router (192.168.0.1) itself succesfully with <1ms and 0% loss. A few times in the past I've had to run through the setup again after returning from being away and it's been fine - but this time, I simply can no longer connect to the internet with it - and I have no wifi in my home office without it...

Anybody with any suggestions?


Nick Gammon

Some kind of password issue? Try turning both off, turn on the router first, wait a few minutes, then turn the repeater on.

If you can connect to the repeater (via its web interface or whatever) see if the security setting are right.
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

MattS-UK

I am not particularly familiar with the Edimax but it sounds like you might have the wrong default gateway and/or DNS server address configured on the client.

Try setting up the client IP configuration manually, using the following
IP address = 192.168.0.254 mask=255.255.255.0
Default gateway = 192.168.0.1
Primary DNS = 192.168.0.1 secondary DNS 8.8.8.8

Does that help at all?

Also worth trying to ping 8.8.8.8 which is Google's DNS server.

jtw11

Hi both,

Thanks for your replies - I've manually configured the client computer now with the addresses you've specified. I have the problem of not being able to reach the internet on both PC and Mac, but I'm doing this on Mac at the moment.

I can wirelessly connect and login to the repeater control panel on 192.168.0.50 and have turned off encryption to see if that was the issue, but I still can not actually get to any web addresses.

I can ping the repeater fine of course, but cannot ping the router itself - just get a timeout.

I cannot ping 8.8.8.8 either, just another timeout.

If I turn the IP settings back to manual, it self assigns itself an IP of (this time) 169.254.222.130 and "will not be able to connect to the internet". When using the manual settings, that error message goes away - but none the less I have no internet connection.

Seeing as I can't ping the router whilst connected to the repeater, surely that implies the repeater isn't actually repeating the wifi signal?

MattS-UK

It sounds like the routers radio signal is not reaching the Edimax, hence you get no IP traffic traveling beyond the Edimax.

Have a look in the Edimax admin page.
Is is set as extender/repeater?
Is there a ping utility and if so, can you ping from the Edimax to the Router?
Can you move the Edimax nearer to the Router and if so, does it help at all?

There are couple different methods of extending a WiFi segment. 
The one I am most familiar with involves the extender connecting to the router as a WiFi client.
The extender's encryption settings have to match the routers.
The extender's MAC address should show up as a connected WiFi client on the router.


jtw11

Problem solved...

I used to use a different router, and we had a different password on the repeated network as compared to the router itself - just with the same encryption type.

With this new router, the two passwords have to match - trial and error, and now it works. Thanks for all your help.

Go Up