Pages: [1]   Go Down
Author Topic: Problem with code "copy for forum" containing [i]  (Read 1071 times)
0 Members and 1 Guest are viewing this topic.
Lyon FRANCE
Offline Offline
Newbie
*
Karma: 0
Posts: 11
You can’t put an old head on young shoulders...WHY NOT?
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I have posted some code containing "[" "i" "]" as variable index.
The forum seems to ignore this specific sequence of 3 caracters and I wonder why...
In the folowing on line 10, my code is:
Flag"[" "i" "]" = true;
And it become:
Flag = true;

This append when doing "copy for forum" and also when doing normal copy and paste.
Any idéa?

//Interrupt Service Routine On Timer Overflow
ISR(TIMER2_OVF_vect) {
  for (int i=0; i<ChannelNbr; i++){
    //Increment Overflow Counter
    T2_OverFlow++;
    if (T2_OverFlow > 25) {
      //Fail Safe Value
      PulseLenght = FailSafeVa;
      //Set Flag
      Flag = true;
    }
  }
}
Logged

Salutations Amicales (from France)

Global Moderator
UK
Offline Offline
Brattain Member
*****
Karma: 238
Posts: 24346
I don't think you connected the grounds, Dave.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Use code tags.
I mentioned this in your other thread.
Don't use copy for forum.

Voila
Code:
ISR(TIMER2_OVF_vect) {
  for (int i=0; i<ChannelNbr; i++){
    //Increment Overflow Counter
    T2_OverFlow[i]++;
    if (T2_OverFlow[i] > 25) {
      //Fail Safe Value
      PulseLenght[i] = FailSafeVa[i];
      //Set Flag
      Flag[i] = true;
    }
  }
}

sp. "Length"
« Last Edit: July 25, 2013, 11:52:36 am by AWOL » Logged

"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

Lyon FRANCE
Offline Offline
Newbie
*
Karma: 0
Posts: 11
You can’t put an old head on young shoulders...WHY NOT?
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you for the trick!

I tried to modifie my post using normal copy and past between codes tags.
But even when using code tags as you propose the quoted i [ i ] does not go through...
Quoted j [j] does but quoted [ i ] does not!  (quote/space/i/space/quote in purpose to make it visible)
Look at this:

Quoted j [j] between code tags:
Quote
[j]

Quoted i [ i ] between code tags:
Quote


Grrrrrr....(Is my bloody Azerty key pad driving me crazy?)

Thanks for help.

Length, length, length (I get it now).
« Last Edit: July 25, 2013, 02:55:46 pm by FlyAwayFR » Logged

Salutations Amicales (from France)

Global Moderator
UK
Offline Offline
Brattain Member
*****
Karma: 238
Posts: 24346
I don't think you connected the grounds, Dave.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Code tags look like this [code][/code] and do this
Code:
You have used quote tags, which look like [quote][/quote] and do this
Quote
Logged

"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

Lyon FRANCE
Offline Offline
Newbie
*
Karma: 0
Posts: 11
You can’t put an old head on young shoulders...WHY NOT?
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

Not a good feeling but I have to admit "the crazy frog" is also stupid...
I did not get right the diff between quote tags and code tags!
Now I think my post is clean.
Thank again for the bad feeling you gave me.

Cheers.
Logged

Salutations Amicales (from France)

Pages: [1]   Go Up
Jump to: