Go Down

Topic: Arduino et Linux Mint (Read 2847 times) previous topic - next topic

chris4775

Bonjour
Je vais essayer d'être clair. J'ai installé il y a 6 mois Arduino 1.0.3 en téléchargement sur le site de base. Déplacement du tgz dans dossiers personnels et extraction. Mise en place de mes sketchbooks et librairies. Sudo usermod, vérification du dialout   et roule kiki.
Aucun problèmes pendant 6 mois. Téléversement plus rapide que sur windows que du bonheur.
Et puis, un jour en plein développement, j'envoie un fichier et bug de téléversement. Une pleine page d'un instant à l'autre. Aucune modifs, pas d'arrêts intempestif rien.
Bien sûr je n'ai rien compris. c'est du chinois pour moi et j'ai donc tout rechargé ,vérifié, recommencé et finalement direction la poubelle avant de fracasser mon bel écran Eizo.
J'ai une copie d'écran du méchant message. C'est toujours le même depuis 1 mois.
Merci de votre aide.
Christian

skywodd

Bonjour,

Branche ta carte puis fait ceci :
Code: [Select]
uname -a
ls -l /dev | grep tty
lsusb
lsmod
apt-cache show librxtx-java
dmesg | tail -n 30 -

Et donne nous les résultats ;)
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

chris4775

Bonjour skywood et merci pour cette aide précieuse.
Voir les PJ ( la deuxième était un peu longue j'ai centré sur les "tty acm0"
bon courage.
Christian

chris4775

Je continue ...

skywodd

Ok donc ce n'est pas :
- un problème de driver (la carte est bien détectée)
- un problème de droits sur /dev/ttyACM0
- un problème de lib rxtx java
Conclusion c'est un problème lié à l'ide Arduino.

Je suis allez voir le code source de la partie qui pose problème.
Supprime le fichier "~/.arduino/preferences.txt" puis de relance l'ide (il sera automatiquement régénéré) et regarde si le problème persiste ;)
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

chris4775

bon sang de bon sang !!! C'est pas possible !!! C'est toi qui a fabriqué ce foutu Arduino.

J'ai exactement fait ce que tu m'as dit, c'est reparti du premier coup.
J'ai réinstallé mes sketch et mes librairies dans home comme on me l'a expliqué et j'ai uplodé le programme GPS le plus compliqué que j'avais et cela a fonctionné.

Merci, mille fois merci. J'ai rien compris bien sûr mais je sais que tu es très fort là dessus.
Si tu peux me dire simplement ce qui a pu se passer je dormirai moins bête ce soir ou demain....

Je t'envoie les deux fichiers en cause, le Old et le nouveau. cela te donnera certainement des raisons de te réjouir.

Bravo et merci

Christian

skywodd


bon sang de bon sang !!! C'est pas possible !!! C'est toi qui a fabriqué ce foutu Arduino.

Non, mais j'ai tellement retourné le code source de long en large et en travers que je le connais par cœur :smiley-mr-green:


Merci, mille fois merci. J'ai rien compris bien sûr mais je sais que tu es très fort là dessus.
Si tu peux me dire simplement ce qui a pu se passer je dormirai moins bête ce soir ou demain....

En fait le problème vient de la constante "serial.debug_rate", si elle n'est pas fixée à 9600 l'ide plante.
Faut pas chercher à comprendre, ya pas vraiment de logique là dedans ...


Je t'envoie les deux fichiers en cause, le Old et le nouveau. cela te donnera certainement des raisons de te réjouir.

Tient, quel hasard ! :)
Avant (bug) : serial.debug_rate=28800
Aprés (plus bug) : serial.debug_rate=9600
Maintenant la question serait de savoir comment la constante c'est retrouvée fixée à 28800bps mais là c'est une autre histoire ...
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

chris4775

Encore merci skywodd pour cette aide appréciable et appréciée.
Bon courage à toi et à un de ces jours j'espère pour en apprendre un peu plus.
@+
Christian

Go Up