Go Down

Topic: Nuelectronics Ethershield not working? (Read 4152 times) previous topic - next topic


Ok, so I've tried everything to get the ethershield working, but I can't seem to get any response from the shield. The lights are blinking, so data is being received by the shield but I don't see any data comming back. I've tried a direct connection (pc->ethernet shield) and also through a switch, and a router but nothing seems to be working.
I even tried a new shield but that one seems to have the same problem, which makes me think I am doing something wrong. I've tried all the examples (webserver, webclient, ping etc) but to no avail.
Also I've tried the shield with a different arduino board but again.. that didn't work either.

Is there anyone with the same problem? Or could anyone help me to get the shield working?


If you are using a mega, you have to change some pins, and a file.
in that case, search the forum, there a threads like "ethernet mega hack" or similar.

did you enter your IP to the sketch? Is that IP in the same network as your computer?


I'm not using the mega, I'm using the diecimila. And yes I've checked the ip and mac address.


Nov 15, 2009, 03:04 pm Last Edit: Nov 15, 2009, 03:17 pm by Cypher87 Reason: 1

I think I'm missing something, but I feel like I've tried everything. I just don't get a response from the shield. Nuelectronics isn't answering my mails, so I'm totally lost now.
Just wondering if someone could help me out here....  :-/


If the LEDs are blinking then data is getting through. What is almost defiantly the problem is the IP address. It has to match all but the last digit of your PC. Also the sub net mask on your PC should be

I had the same problem, emails not being answered but no LEDs apart from the power on at all. I switched to another shield and it now works. I used a crossed Ethernet cable to connect directly to my Mac and got all examples to work.

Best of luck.


Nov 17, 2009, 03:16 pm Last Edit: Nov 17, 2009, 03:17 pm by Cypher87 Reason: 1
Thanks for your reply.

The subnetmask is indeed (using

I will try some more cables, the only thing I can think of what might be wrong. Though it sucks that mails don't get answered.

Not enough information available for this shield :(


Nov 17, 2009, 04:10 pm Last Edit: Nov 17, 2009, 04:10 pm by Grumpy_Mike Reason: 1
Try not using 0 as the last digit of the IP address, change it to 1. I think 0 is reserved for the server or something.


I've tried the default (

( is an ip prefix)


What OS are you using? I will try and duplicate it if you like (if I have access to that OS)


Using Windows 7, though I have also tried with Windows XP



I have a number of these ethernet shields and have had a lot of success with them. Which library are you using? The one that comes from nuelectronics is a bit limited in that it wont route outside of the local lan.

I had created an updated library that a number of people have had success with. It is able to route to internet servers and I use it to post data to pachube.com and twitter.

Its available at http://blog.thiseldo.co.uk/?p=329. The library is not perfect and there is room for improvement and might get round to re-visiting it sometime soon!

I have also have created a new library for the nuelectronics nokia 3110 lcd shield.

Hope this helps.  ;)





Have you tried to ping it?
If it comes back and says the address is unreachable then it is something wrong with your network settings in your PC.


I can't ping, but the settings are ok.


Check out:

Go Up