Pages: [1]   Go Down
Author Topic: Real-time Datalog & IO shield v1.0 (Problem)  (Read 775 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Full Member
***
Karma: 1
Posts: 178
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I recently purchased the Real-time Datalog & IO shield v1.0 for Arduino from here: http://www.nuelectronics.com/estore/index.php?main_page=product_info&cPath=7&products_id=20

and the humidity, temperature and gas sensors...

The thing is that when I upload the sketch of the datalog shield, the serial monitor gives me characters like that....
"^Ò
@ã"

and when i upload the sketch of the humidity sensor (P4) it gives me the charactes pasted below:
"„>󁥭„††ì††„I„„ľ…„…x¤ä$
bå䄆††††D‡„„¼„…„¿Ä¤äš„bü¥ä
†††
†„‡
„Ä„„…Ä\ä$„"

Why is that????
Please help because I paid lots of money  for the shields and sensors and I cannot make it work...It doesn't give me enough information on how to make it work...
I don't use an SD card...
« Last Edit: June 27, 2010, 08:58:38 am by nathanas » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 15
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Try setting the serial rate on the Arduino serial monitor screen to 57600 baud for the data log sketch
and 19200 if your just using the temperature/humidity sketch
HTH
« Last Edit: June 27, 2010, 10:33:36 am by geppetto » Logged

0
Offline Offline
Full Member
***
Karma: 1
Posts: 178
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

do i need to enter so high values?
The consumption of my arduino is going to be increased cause of that change?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 15
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What you need to do is set your serial monitor baud rate to the same as
the baud rate setup in the sketch listings.

If they aren't the same then your monitor will show garbage text.

Maybe you could use a lower baud rate, not sur really.
If you do alter it in the listings then again match it in the monitor settings.. smiley
Logged

0
Offline Offline
Full Member
***
Karma: 1
Posts: 178
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

thanks a lot...
I forgot setting the baud rate the same with my pc and that's what was the problem!
thanks Philip...
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 15
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Will be interested to see how you get on with your board...
I got one yesterday with a temperature/humidity sensor and I'm having a
first time go with it today...

Got the computer talking to it via serial OK but I can't get the time to set.
It accepts the numbers (month day etc) but the clock refuses to start or change time.

Just scratching my head what to do about that >smiley-sad
Logged

0
Offline Offline
Full Member
***
Karma: 1
Posts: 178
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i don't have the time to work on my project this week a lot...
I am having exams at my university. So from the next week I'll be spending a lot of time on programing my arduino....hopefully!
I'll let you know about it.
Logged

Pages: [1]   Go Up
Jump to: