Go Down

Topic: Non riesco a collegarmi ad Arduino MINI Rev5 (not sync) (Read 973 times) previous topic - next topic

Federico0

Aug 22, 2013, 04:24 pm Last Edit: Aug 22, 2013, 05:05 pm by Federico0 Reason: 1
Niente, il titolo dice tutto..
Ho acquistato Arduino MINI 05 e mi sono collegato al USB2Serial light come anche spiegato qua, ho fatto attenzione a RX->TX e viceversa, ho installato i driver corretti (ne ho installati tanti ma sinceramente mai nessuno mi ha dato la certezza fosse quello specifico per il Mini e poi quello specifico per l'usb2serial), ho cambiato IDE, la porta sembra OK ma ogni volta che provo a uploadare lo sketch mi da sempre l'errore arduino not in sync.. e i codici sono 0x92 oppure 0x93, tenendo premuto il reset invece 0x00, premendo shift invece per ora l'unica informazione aggiuntiva che mi è arrivata era tipo nessun dispositivo collegato ma poi mai più avuta..
Sinceramente non so proprio come fare .-.
Non mi è chiara la storia dei driver FTDI a dire il vero, che si cieli lì la chiave?

Edit:
Nuovo errore

avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

Grazie per l'aiuto a tutti quanti :)

nid69ita

Scusa, la domanda può sembrare scema, ma nell'IDE hai settato il tipo di board giusta?
my name is IGOR, not AIGOR

Federico0

Sì sì, ho settato Arduino Mini w/ Atmel mega328 e poi anche tutte le altre per provare  :)

nid69ita

Come 093 ho trovato questo:
http://www.instructables.com/id/A-solution-to-avrdude-stk500getsync-not-in-syn/
in inglese.
my name is IGOR, not AIGOR

Federico0

#4
Aug 23, 2013, 10:06 am Last Edit: Aug 23, 2013, 10:36 am by Federico0 Reason: 1
Ti ringrazio dell'aiuto ma purtroppo ho trovato anche io quel link ma non sono riuscito a risolvere lo stesso..
Penso sia un problema di driver anche se è molto strano perchè l'usb2serial lo ho usato per programmar l'ethernet senza problemi di nessun tipo.. forse con il mini c'è qualcosa che non va.. o i collegami ? ma pure quelli li ho controllati più e più volte..
Se qualcuno ha un accorgimento particolare da seguire sarei davvero felice.. altrimente presto dovrò comprare l'arduino nano che almeno ha l'usb integrato.. + grande ma - noie


Comunque, per completezza d'informazioni: se vado su Gestione dispostivi e mi sposto su PORTE E COM vedo che sulla porta COM3 c'è ARDUINO USB SERIAL LIGHT ADAPTER e questo mi fa pensare che i driver siano corretti, eppure!

nid69ita

#5
Aug 23, 2013, 10:52 am Last Edit: Aug 23, 2013, 11:00 am by nid69ita Reason: 1
Io per la mini pro uso questo:
http://www.ebay.it/itm/FTDI-Basic-Breakout-USB-TTL-6-PIN-3-3-5V-For-Arduino-Micro-USB-/221248867340?pt=LH_DefaultDomain_15&hash=item338375cc0c&_uhb=1

Quel dispositivo non lo conosco. Però io proverei a disinstallare i vari driver che hai installato e reinstallerei quelli ufficiali:
http://arduino.cc/en/uploads/Main/Arduino_USBSerial.zip
my name is IGOR, not AIGOR

Federico0

Riprovo ancora, ma ovviamente ho disinstallato i vari driver.. provandone uno volta per volta.. beh, per ora grazie e vi farò sapere !

pitusso

Ciao,
se hai una UNO/2009 puoi provare a programmare la Mini in questo modo:
- rimuovi l'atmega328 dalla board UNO/2009
- colleghi come qui sotto elencati i pin dalla UNO/2009 alla Mini
RX -> RX
TX -> TX
5V -> 5V
GND -> GND
RST -> RST
- colleghi la UNO/2009 al PC
- selezioni sull'IDE la board corretta (Arduino Mini w/ atmega328, come già avevi fatto)
- upload

Questa procedura la trovi anche come guida ufficiale (non ricordo dove) e anche nella guida omnia del prof. Menniti



Federico0

Grazie del consiglio!

Diciamo che grosso modo sono riuscito a programmare arduino ma devo ammettere che ogni volta che voglio inviare il codice devo "reinstallare" i driver che mi hanno dato..

Non saprei.


pitusso

Quote
ogni volta che voglio inviare il codice devo "reinstallare" i driver che mi hanno dato..


non capisco cosa intendi: perchè mai dovresti reinstallare i driver ogni volta?

nid69ita


Quote
ogni volta che voglio inviare il codice devo "reinstallare" i driver che mi hanno dato..

non capisco cosa intendi: perchè mai dovresti reinstallare i driver ogni volta?


Già. Ma poi, manca una info. Quale sistema operativo usi? linux, mac, windows? e che versione?
my name is IGOR, not AIGOR

Federico0

Per quanto riguarda l sistema operativo: win7 hp x64 e lo ho dato per scontato in quanto nei post precedenti parlavo di gestione dispositivi, porte e com e quant'altro..
Versione dell'IDE ? ho provato con la 1 e con la 1.05
Infine, reinstallare i driver nel senso che se carico uno sketch funziona, se lo ricarico perché ho fatto alcune modifiche no, non riesce a caricare e devo rifare la procedura di installazione del driver e solo ora riesco.

mikko90

:-) provato a mettere un condensatore ceramico prima del reset ?

Go Up