Go Down

Topic: Ayer Arduino Micro... hoy no Arduino Micro. (solucionado) (Read 927 times) previous topic - next topic

naho

Aug 29, 2013, 11:46 am Last Edit: Sep 12, 2013, 12:55 am by naho Reason: 1
Hola compañeros:

Alguien puede decirme que pasa con las interrupciones externas en el arduino Micro.

Monté este circuito http://arduino.cc/es/Tutorial/Button pero por el pin 3 y le cargué este programa. http://arduino.cc/en/Reference/AttachInterrupt
Estuvo funcionando unos segundos, después dejo de funcionar. Cuando intente cargarle el programa Blink para ver si funcionaba, Windows me dice que ya no reconoce el dispositivo.

Intenté conectarlo en otra máquina con linux y lo mismo no reconoce el dispositivo.


¿Alguna idea de porque pasa eso?
¿Me he cargado la placa o sólo el bootloader?
¿Alguna solución?


Muchas gracias a todos.

naho

Lo curioso es que aunque windows no me detecta el dispositvo. El sketch que metí está funcionando a la perfección.
Este fue el ejemplo que le metí:

Code: [Select]
int pin = 13;
volatile int estado = LOW;
void setup(){
  pinMode(pin, OUTPUT);
  attachInterrupt(0, parpadeo, FALLING);
}
void loop(){
  digitalWrite(pin, estado);
}
void parpadeo(){
  estado = !estado;
}






vxie13


la verdad, no se porque dejo de reconocer el dispositivo. Has intentado volver a instalar los drivers?

Cómo sabes que si funciona el sketch?

No sé cuales son los pines dedicados a las interrupciones del arduino Micro, puedes checar si ese pin sirve como interrupcion externa.




naho

Muchas gracias por contestar.

Quote
Has intentado volver a instalar los drivers?

Lo intenté pero me decía que ya los tenía instalados


Quote
Cómo sabes que si funciona el sketch?

Porque aunque el ordenador no me reconocía el dispositivo, si montaba el circuito, al pulsar el botón se encendía el led.

Quote
puedes checar si ese pin sirve como interrupcion externa

En principio el pín era el correcto, de hecho el circuito estaba funcionando.



Al final me he hecho un programador paralelo, le he cargado el bootloader y el ordenador ha vuelto reconocer el dispositivo correctamente.  XD

Pero no sé que pasa, porque cada vez que cargo este sketch pierdo el bootloader. Y me ha pasado con dos placas diferentes de arduino micro.   :smiley-eek:

Un saludo.

noter

¿ Has probado reseteando el arduino cuando comienza el upload (no la compilación) del sketch?. Mi mega a veces se vuelve "sordo" tras cargar ciertos programas y de esa forma se despierta. Creo que las interrupciones tienen algo que ver.

naho

Hola noter, no se si te he entiendo bien:


¿Quieres decir, que aunque el ordenador no me reconozca el arduino, le doy a la flechita "Subir" para que se cargue el sketch, espero mientras el programa pone "Compilando programa..." y justo cuando diga "Subiendo..." le de al botón del reset de la placa?

Voy a probarlo!

naho

Joer! a la primera, ¡eres un genio!

Y no sólo ha cargado el sketch, además el ordenador ha vuelto a reconocerme la placa sin necesidad de cargar el bootloader.


Casi me da algo hace una semana cuando me dejó de contestar la segunda placa, y al final se soluciona con una chorrada como esta.

Muchas gracias.

Go Up