Pages: [1]   Go Down
Author Topic: Spannungen  (Read 515 times)
0 Members and 1 Guest are viewing this topic.
Germany
Offline Offline
Newbie
*
Karma: 2
Posts: 32
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ich habe mal nur so zu Kontrolle ein Oszilloskop an einen PWM-Pin angelosssen (Mit dem regele ich die Displayhelligeit)
und mich irgendwann gewunder das das Skope weniger als 5V anzeigt.
Ich habe dann mit dem Multimeter die 5V mal angeschaut und sehe da auf dem Arduinoboard nur knapp 4.6V.
(Megaarduino). Rein gehe ich mit einem Steckernetzteil das auf 8V eingestellt ist oder mit meinem Labornetzteil
das ich dann meist so auf 7V stelle.
Ist aber keine Ausnahme.
Ein anderer Mege (ohne weitere Beschaltung) und zwei andere Arduinos zeigen die gleichen Spannungswerte.
Ich dachte hinter dem Spannungsregler sollte 5V sein.
Ist das normal ?

Ulli
Logged

Offline Offline
God Member
*****
Karma: 12
Posts: 593
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

2 Volt Differenz sollten eigentlich reichen. Welcher Spannungsregler ist auf dem Board drauf?
Logged

Germany
Offline Offline
Newbie
*
Karma: 2
Posts: 32
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Das muß ich heute Abend mal nachschauen.
Ich muss aber dabei sagen das alles ordnungsgemäß funktioniert.
Messgerät und Oscar zeigen auch die gleichen Werte an, daher nehme ich
an das ich richtig messe. Das Multimeter zeigt auch bis auf 0.1 V die Spannung
an die ich am Labornetzteil messe.
Aber wie gesagt, vier Arduinos zeigen das gleiche Verhalten (und arbeiten alle).

Ulli
Logged

Offline Offline
Edison Member
*
Karma: 39
Posts: 1173
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Der interne Regler meines Mega2560 gibt 4,99V aus, wenn ich über USB speise, dann habe ich  nur 4,56V.

Ist aber kein Problem, der arduino läuft auch mit 4V noch.
Logged

Grüße
Gunther

Offline Offline
God Member
*****
Karma: 14
Posts: 586
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

wenns Dich wirklich interessiert, kannst Du ja mal im USB-Betrieb die Spannung am Drain von T1 messen. Und dann am Source von T1. Vielleicht erklärt sich da die Differenz. Mein Mega sollte seit heute per Post zu mir unterwegs sein. Wenn der hier ist, messe ichs mal nach.

Gruß,
Ralf
Logged

Es gibt 10 Arten von Menschen, die einen verstehen Binär, die anderen nicht...

AREA COLOGNE
Offline Offline
Edison Member
*
Karma: 21
Posts: 1141
I am 1 of 10 who understands binary
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Die Geschicht mit den unterschiedlichen Spannungen an USB und über Vin kommt vor allem dann in die quere wenn man mit den ADC arbeitet. Dann sind 300Bit(5V/1000*300=1,46) an USB nicht gleich 300Bit(4,6/1000*300=1,38V) an der Vin und da kann gerade bei Temperaturmessungen mit Analogen Sensoren doch für einige Verwirrung sorgen.
Deswegen besser ein Netzteil an min 8V an Vin oder eben an den Powerjack. USB wenn für Serial ist dann immer noch funktionsfähig.
Gruß
Der Dani
Logged

So ist das Leben:
Manchmal bis du das Denkmal, manchmal die Taube!

Offline Offline
Edison Member
*
Karma: 39
Posts: 1173
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Die Geschicht mit den unterschiedlichen Spannungen an USB und über Vin kommt vor allem dann in die quere wenn man mit den ADC arbeitet. Dann sind 300Bit(5V/1000*300=1,46) an USB nicht gleich 300Bit(4,6/1000*300=1,38V) an der Vin und da kann gerade bei Temperaturmessungen mit Analogen Sensoren doch für einige Verwirrung sorgen.

Das stimmt nur, wenn du aktive Temperatursensoren hast die eigenständig eine Spannung abgeben. Meist arbeiten die Temperatursensoren aber als Spannungsteiler mit einem internen Pullup-Widerstand auf die 5V.
Nun kommt der Gag: wenn die 5V, mit denen der Spannungteiler gespeist wird, die gleichen 5V sind, die für den AD-Wandler verwendet werden (das ist beim Arduino standardmäßig so), dann kürzen sich Fehler raus.
Es ist also egal, ob du nun 5V, 5.5V oder 4.5V hast, dein Ergebnis ist immer korrekt!
Logged

Grüße
Gunther

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21842
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ja, wie guntherb sagt:
Sensoren, die als Spannungsteiler geschalten werden, erfahren keinen Fehler, wenn sie an der Versorgungsspannung hängen und die Versorgungsspannung als Referenzspannung für den ADC verwendet wird. Wenn eine externe (zB3,3V) oder die interne 1,1V Referenz verwendet wird dann unterliegen sie dem Einfluß/Fehler der veränderten Versorgungsspannung.

Bei Sensoren und Schaltungen, die eine Spannung ausgeben die proportional zur Meßgröße, aber unabhängig von der Versorgungsspannung ist, verhält es sich genau umgekehrt. Diese sind ungenau bei Schwankungen der 5V Referenz, aber genau bei anderen Referenzen.

Eine möglichkeit den Fehler zu kompensieren ist intern die 1,1V Referenz zu messen und dadurch auf die Versorgungsspannung zu schließen.
zB: http://code.google.com/p/tinkerit/wiki/SecretVoltmeter

Grüße Uwe
Logged

Offline Offline
God Member
*****
Karma: 14
Posts: 586
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

... Wenn der hier ist, messe ichs mal nach.
Nur der wegen der Vollständigkeit: 5,05V.
Logged

Es gibt 10 Arten von Menschen, die einen verstehen Binär, die anderen nicht...

Pages: [1]   Go Up
Jump to: