Go Down

Topic: USB to TTL Problems CP2102 ATMega328P-PU [SOLVED] (Read 2535 times) previous topic - next topic


Aug 31, 2013, 11:14 am Last Edit: Sep 03, 2013, 12:20 am by tmcisaac Reason: 1
So... I know this dance has been done. Seen many other posts, it did not work for me. Seems there weren't much "solid" solutions.

I have this CP2102 USB to TTL/UART programmer, it looks exactly like this but i didn't buy from this site.

Tested on Mac(OSX 10.7.5) and Windows7 it just doesn't want to work. I have tried different baud rates, the reset/upload "trick" and messed around in the terminal with screen. Even just tried to switch the Tx/Rx. My first try was with the USB Tx to the ATMega's Rx and vice versa.

Same layout as the Arduino on a breadboard.

Attached is a bit more info too.

I bought an ATMEGA328p-pu with a bootloader on it already.
Plugging the ATMega328p-pu into an Uno R2 works, same chip right, but i don't want to pry a chip off the board every time i need to re-program it.

Hope we can fix this here and now.
I would love the help guys and gals.

Fix: Just keep trying the Upload/reset trick. For my ATMega328P-PU I used the Uno Board, AVRISP mkII programmer and with the verbose output as your indicator, when the uploader starts with its "avrdude: send" you can hit the reset.


if i'm correct you set a wrong programmer in avr dude


What programmer should I be using?
I don't really know much about the avrdude.


Bad news because the auto reset will not work with that chip on the Mac. It is the fault of the chip's drivers not changing the DTR pin when the port is opened. This means you have to hit the reset manually when you try and program an Arduino. This is tricky and dosn't always work.


Thanks, I methodically tested the reset timing with the verbose output as an an indicator. Seems to work.

Go Up