Go Down

Topic: Problem with wifi shield (Read 1 time) previous topic - next topic

Everlance

Hi all, i recently just got a new wifi shield. i mounted it onto the arduino uno r3 but it doesn't seem to be working. i tried running the scannetworks example code and it said cannot detect wifi shield. can anyone help me please?

Everlance

Hi all, i have already updated to the latest firmware. Still, "WiFi shield not present" when i run sketch ScanNetwork. Can any kind soul advice me please? Thank you... Using IDE 1.0.5 fyi...

Everlance

upzzz! Anyone solved this problem before? I really do need to get this working for a project. I am using uno r3 and my wifi shield model is R3. IDE 1.0.5. also tired with 1.0.3. same problem.

Everlance

Bumpz... Can anyone help me please!

fpga6

Where did you get the latest wifi shield firmware?  Did you load the firmware from the "hardware" folder that was created when you installed IDE 1.0.5?

Everlance

yes, I flashed the firmware from the hardware folder that was created when i installed ide 1.0.5... I am very sure the jumper wire near vin and A0 is not connected when i load the scannetwork script. Still, wifi shield not detected.


Everlance

Hi ale16289, thanks for responding. I have tried the following methods and the problem still exist. I usually use batchisp to update my firmware and it usually does it without any errors. Is is ok for you to send me the working version of the firmware (wifiHD & wifi_nld) of your wifi shield? Also, are you using an external power source or just powering using usb.

ale16289

#8
Sep 20, 2013, 09:31 pm Last Edit: Sep 20, 2013, 09:36 pm by ale16289 Reason: 1
sorry for the delay...try with this two file

ale16289

this is the second

Everlance

thank you so much ale16289, I'll try it out and get back to you.

cjdelphi

Does the shield even power up? lights come on (surface mounted LED's) ? lights flicking once connected to a router?

Everlance

@ale16289 - I tried flashing both firmwares but they didn't work. Could it be that my flashing method is wrong? I followed the instructions here http://arduino.cc/en/Hacking/WiFiShieldFirmwareUpgrading. Do I need an external power supply?

@cjdelphi - When I flash the wifi_dnld.elf the link led comes on for awhile before the data led turns on. Ran scannetwork sketch, 'wifi shield not present'. After flashing wifiHD.elf, totally no led on at all, same problem when running scannetwork.

btfdev

You might want to follow our notes on updating Wifi shield firmware.

http://www.binarytaskforce.com/Weblog/2013/09/21/arduino-wifi-firmware-update/

Good luck, Team BTF

ale16289

few days ago i posted in this conversesion one link that explain to you teh step to do for upgrade the firmware...here there is the link
http://www.dfrobot.com/community/how-to-upgrade-arduino-wifi-shield-firmware-on-windows.html.

Go Up