Go Down

Topic: [AIDE] Ecran serial lcd crius arduino duemilanove (Read 959 times) previous topic - next topic

Snyp

Bonjours a tous.
Je suis en train de réaliser une glacière avec une arduino duemilanove, un shield relais, une cellule peletier, un capteur DHT11 et un écran lcd serial crius.
Au niveeau de mon code la gestion température déclenchement relais fonctionne avec retour des information dans la console.
Mais sa fait deux semaines que j'essaye de faire marché mon lcd en vain.
Pourriez vous m'orienter??? Mon lcd en question est celui-ci http://www.fast-lad.co.uk/store/multiwii_monitor_16107999-p-18114.html?language=fr.
Cordialement

Christian_R

Déjà, est ce que l'écran s'allume (rétro-éclairage) ? arrive à affiche des caractères mais du chinois , ou rien du tout ?
Christian

Artouste


Bonjours a tous.
Je suis en train de réaliser une glacière avec une arduino duemilanove, un shield relais, une cellule peletier, un capteur DHT11 et un écran lcd serial crius.
Au niveeau de mon code la gestion température déclenchement relais fonctionne avec retour des information dans la console.
Mais sa fait deux semaines que j'essaye de faire marché mon lcd en vain.
Pourriez vous m'orienter??? Mon lcd en question est celui-ci http://www.fast-lad.co.uk/store/multiwii_monitor_16107999-p-18114.html?language=fr.
Cordialement

bonjour
cd lcd semble devoir etre commandé en I2C selon un "protocole" multiwii
http://www.multiwii.com/
tu a testé une comm en natif ?

Snyp

#3
Sep 01, 2013, 12:18 pm Last Edit: Sep 02, 2013, 06:23 pm by Snyp Reason: 1
Alors l'écran s'allume m'affiche LCD SERIAL v1.03, et m'affiche la console mais bout a bout, j'aimerais pouvoir normaliser sa.
EDIT: Caractère chinois en faite

Snyp

#4
Sep 02, 2013, 06:24 pm Last Edit: Sep 02, 2013, 10:22 pm by Snyp Reason: 1
J'ai effectué des test avec la librarais liquid Crystal et wire en vain. Dans le code multiwi il y a une adresse I2C "0XC6" mais ne marche pas non plus.

EDIT:
Voila a quoi ressemble l'adaptateur
http://www.youtube.com/watch?v=UoOYWAKNWRY

Et voici ce que j'obtient en connectant la pin tx arduino à l'écran
http://www.youtube.com/watch?v=8zOhJ9ZUk7A

Snyp

Personne pour me donner un coup de main ?  :smiley-fat:

Christian_R

Christian

Snyp

Désolé j'avais pas vu la video privée, c'est rétablie.

Snyp

Bonjours, j'ai avancer dans mes recherches, donc apparament, pour dialoguer en série, l'écran et interfacé à une puce ATMEGA48pa.
Je vien de mettre un fichier .hex avec un usbasp relié à l'ATMEGA48pa.
http://www.multiwii.com/forum/download/file.php?id=1051
Voici le lien du fichier que j'ai injecté.
Maintenant l'écran m'afficher plus de signe chinois.

Maintenant j'aimerais savoir comment je peut faire pour que l'écran se comporte correctement.
C'est à dire,
écrit sa ligne 1 colonne 3
éfface l'écran
etc....

Je vous remercie.

Go Up