Pages: [1]   Go Down
Author Topic: ATMEL Studio 6.1 + VISUAL MICRO for DUE  (Read 1286 times)
0 Members and 1 Guest are viewing this topic.
Germany
Offline Offline
Jr. Member
**
Karma: 0
Posts: 57
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi guys,
I have installed both AS6.1 and the VISUAL MICRO plugin for DUE support freshly out of the box. I get support for the Arduino Uno but not for Due. When I set the path in the application manager for Arduino 1.52 nothing happens, the setting is ignored.

This is the path where the file arduino.exe is located:
C:\ARM_ARDUINO\arduino-1.5.2-windows\arduino-1.5.2

Anyone an idea?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 37
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had a similar problem, gave up. I later found this but haven't tested it. It is for running the UID retrieval example code.
This might be good start...

Opening the ASF example
1. Open Atmel Studio 6.1
2. Go to File > New > Example Project
3. Type 'unique' in search
4. Select Arduino > Atmel Corp. (ASF 3.9.1) > Flash Read Unique ID Example - Arduino Due/X
5. Select preferred save location
6. Press F7 to build

Uploading the bin file onto Arduino
1. Open command prompt (assuming you're on Windows)
2. Navigate to hardware > tools folder in the arduino folder e.g. "cd C:\Users\PC NAME\Downloads\arduino-1.5*\ard*\hardware\tools"
3. Check status of device by typing "mode com4:1200,n,8,1" (replace com4 by your due's com port - do the same for the rest of the code accessing at com4). The command should return the device status.
4. Check bossac by typing "bossac.exe --port=COM4 -U false -i". The command should return info about your device e.g. Device, Chip ID, Version, etc
5. Upload the bin file using bossac e.g. "bossac.exe --port=COM4 -U false -e -w -v -b "C:\Users\PC NAME\Atmel C\UniqueIdentifierAtmelCode\UniqueIdentifierAtmelCode\Debug\UniqueIdentifierAtmelCode.bin" -R"
6. Test using serial monitor at 115200 baud
Logged

Germany
Offline Offline
Jr. Member
**
Karma: 0
Posts: 57
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Don't believe this will work as "Arduino code". All ASF Code I have seen and used until now is completely written in "standard" C - no C++, no Arduino wrapper for main. Not at all.

But I found out the prob probably comes from the path. At least when I set the path from 1.5.2 for the Arduino 1.0 it also doesn't run.

 
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 37
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
This might be good start...

I spent a long time trying to figure it out, obviously with no luck. Let us know if you make any headway on this please
Logged

Germany
Offline Offline
Jr. Member
**
Karma: 0
Posts: 57
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
I looked at the Visual Micro forum and found other people have the same prob as well. Fortunately there is a update to version 1309.11 available (wich came out some days ago) with runs straight out of the box. Great!


Logged

Pages: [1]   Go Up
Jump to: