Pages: [1]   Go Down
Author Topic: arduino IDE 1.5.4 bug in communicating with labview  (Read 5438 times)
0 Members and 1 Guest are viewing this topic.
india
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hey all
 
i am a new hobbyiest in this area and started working on arduino and labview. I have downloaded the LIFA(labview interface for arduino) and arduino IDE1.5.4 and trying to upload the LIFA base firmware to arduino But i am facing a compile error-"
Arduino: 1.5.4 (Windows smiley-cool, Board: "Arduino Mega 2560 or Mega ADK"
E:\software\arduino_new\arduino-1.5.4\libraries\RobotIRremote\IRremoteTools.cpp: 5: error: 'TKD2' was not declared in this scope
 
 
  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.

"
 
surprisingly when tried to upload the LIFA base with old arduino IDE which is version 1.0.1 it gets successful, i think it because of the new library files of IR remote tools are added in new version of arduino ide. and this libraries has some missing syntax.  i am not sure with whom I should discuss  this error means to the labview side or to the arduino side. so plz help me to troubleshoot this error.




* ardu_error.png (131.26 KB, 1366x768 - viewed 320 times.)
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 601
Posts: 48543
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Are you using a Due? None of the other boards needs 1.5.x. Stick with 1.0.x for boards other than the Due.
Logged

india
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No i m not using due, mine is mega 2560. yes its true that only due and yun board needs 1.5.x version but all other boards are also compatible then y this error is coming.and off course if its a bug then it will create problem for due and yun boards too.
for the sake of time i downloaded 1.0.5 and everything worked . but it doesn't has the IR sensor libraries.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have this same issue. Even running the default demo sketches have the declaring issue. I really hope someone more knowledgable than me can shed some light on this. Is there a work around or a new releasing coming soon to fix this? I tried the nightly build and it did not resolve the issue. I'm working with the Yun.
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 601
Posts: 48543
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I have this same issue.
Specifically, that would be?

Quote
Even running the default demo sketches have the declaring issue.
If you are getting compiler errors, then you are NOT running a demo sketch. If you are getting compiler errors, perhaps you should explain what board you have selected, what code you are trying to compile, and what, exactly, the errors are.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I encountered the same problem.

Removing the files -  libraries\RobotIRremote\IRremoteTools.cpp and libraries\RobotIRremote\IRremoteTools.h solved the problem. They are example files which somehow are getting included. You can move those two files to some other location as backup.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I encountered the same problem.

Removing the files -  libraries\RobotIRremote\IRremoteTools.cpp and libraries\RobotIRremote\IRremoteTools.h solved the problem. They are example files which somehow are getting included. You can move those two files to some other location as backup.

You save my day Thanks a lot..
Logged

Pages: [1]   Go Up
Jump to: