Pages: [1]   Go Down
Author Topic: Yun and TMP36 strange behavior  (Read 938 times)
0 Members and 1 Guest are viewing this topic.
Cintegabelle, France
Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello everybody,

I've setup an Arduino Yun to provide the following graphs :
 - ambient light, with a photo resistor and a voltage divider, which work well : http://malheur.goddess-gate.com/light/
 - ambient temperature, with a TMP36 sensor, which has a strange behavior : http://malheur.goddess-gate.com/temp/

As you may see, there is a regular temperature / voltage drop which happens every 31/32 hours, and I can't explain it, and this voltage drop only happens with temperature measure, not light measure.

The photoresistor and TMP36 are powered by the same +5V pin, photoresistor output is measured with A0 pin, and TMP36 with A1 pin. There's a 100 µF capacitor near VCC and GND pins of the TMP36 sensor.

Light and temperature values are gathered every 10 minutes by a cron job on Linux side via a REST query. Arduino sketch just wait for the REST query and return A0 and A1 values. Temperature measurement is not a single shot : when temperature is asked, I take 10 measure each 1 second, then return the median value.

I can't really explain :
 - Why the voltage drop
 - Why it only happens to temp measure
 - Why it happens regularly, every 31/32 hours.

If someone here have an idea, (s)he's welcome :-)

Thanks
Logged

http://goddess-gate.com/ - My main website
http://raspberrypi.goddess-gate.com/ - A website about (and hosted by) my Raspberry Pi
https://twitter.com/boudouarnaud - Follow me on Twitter

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm sorry I don't have an idea on how to help you with your problem, but would you mind if I asked you how you made sure that cron is running when the board boots up?

I have created a crontab entry, but don't see cron in the ps (process) list. I can see a script for it in /etc/init.d which is linked from /etc/rc.d .... 

HANG ON!

I love answering my own question:

found here, http://wiki.samat.org/CheatSheet/OpenWrt

/etc/init.d/cron enable
/etc/init.d/cron start

Now hopefully the next person to google this will find the answer quicker.   smiley
 
Logged

Pages: [1]   Go Up
Jump to: