Pages: [1]   Go Down
Author Topic: Another Stk500 error  (Read 246 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 23
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello, first I posted this in 'Project guidance'. By the reply it seems it wasn't the right place. I hope this will be the right one! My apologies.

----------------------------------------------
Hello,

I've been reading a lot of literature about the "avrdude: stk500_getsync(): not in sync: resp=0x00". I've seen that there are many reasons for that. I've tried all the fixes, no result. So here it is what I have.

Laptop 64 bits with Windows 7
Arduino 1.0.1 & Arduino 1.0.5 installed
Micro: Arduino Nano 328P

I was able to load scripts in my micro from some months. I tried to load another sketch in the Arduino Nano, and it failed.

I thought  that may be it was a short circuit and my Nano board was damaged. I have another new micro of the same model. I just tried to upload the blink sketch, same result! I cannot upload it.

After that, checked the Selected board & COM ports. They seemed fine.

May be is the cable. Try a different cable --> Same result.

And what if I use a different port in the laptop? --> Same result.

I've also try to maintain the reset button when loading --> Same result

Also I tried to deinstall the virtual ports, and let the system to recognize them from scratch --> Same result.

Btw, my Arduino UNO & FIO seem to work ok (although some months ago I had the same problem in my Arduino UNO).

So I don't know why, but regardless the laptop usb port, the COM port, the correct board in the Arduino 1.0.1 and Arduino 1.0.5, despite of using 2 different cables and 2 Nano boards, I obtain the same error! And if I try with Arduino UNO and FIO, it works. And one week ago I was able (and as far as I remember I haven't done anything in the laptop)

If maintain shif key pressed when loading the sketch, I obtain:

Quote
Tamaño binario del Sketch: 1.084 bytes (de un máximo de 30.720 bytes)
avrdude: usbdev_open(): did not find any USB device "usb"

And If I verbose the load, this is what I obtain:


Quote
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-g++ -c -g -Os -Wall -fno-exceptions -ffunction-sections -fdata-sections -mmcu=atmega328p -DF_CPU=16000000L -MMD -DUSB_VID=null -DUSB_PID=null -DARDUINO=101 -IC:\Master\arduino-1.0.1\hardware\arduino\cores\arduino -IC:\Master\arduino-1.0.1\hardware\arduino\variants\eightanaloginputs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Blink.cpp -o C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Blink.cpp.o
  Using previously compiled: C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\WInterrupts.c.o
...
...
  Using previously compiled: C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\WString.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\WInterrupts.c.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\wiring.c.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\wiring_analog.c.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\wiring_digital.c.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\wiring_pulse.c.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\wiring_shift.c.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\CDC.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\HardwareSerial.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\HID.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\IPAddress.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\main.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\new.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Print.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Stream.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Tone.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\USBCore.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\WMath.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-ar rcs C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\WString.cpp.o
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-gcc -Os -Wl,--gc-sections -mmcu=atmega328p -o C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Blink.cpp.elf C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Blink.cpp.o C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\core.a -LC:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp -lm
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-objcopy -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Blink.cpp.elf C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Blink.cpp.eep
C:\Master\arduino-1.0.1\hardware\tools\avr\bin\avr-objcopy -O ihex -R .eeprom C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Blink.cpp.elf C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Blink.cpp.hex
Tamaño binario del Sketch: 1.084 bytes (de un máximo de 30.720 bytes)
C:\Master\arduino-1.0.1\hardware/tools/avr/bin/avrdude -CC:\Master\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P\\.\COM3 -b57600 -D -Uflash:w:C:\Users\david\AppData\Local\Temp\build7917500689093702052.tmp\Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Master\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.


What could be the reason? Lately I feel that I'm moving backwards rather than improve my arduino skills.  smiley-confuse smiley-confuse smiley-confuse

Thanks for your replies.
Logged

Pages: [1]   Go Up
Jump to: