Pages: [1]   Go Down
Author Topic: Possibly faulty bootloader of a new Arduino Due  (Read 886 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I try to test  a new Arduino Due from eBay. (Other customers of the same seller don't have problems.)
I have experience with Arduno Mega2560 and Nano . I work with latest Arduino IDE version 1.5.4.r2.

1) I have received my old Arduinos with preprogrammed program "blink.ino" from IDE Examples (subfolder "c:\Program Files(x86)\Arduino\examples\01.Basics\Blink" ) and onboard LED on pin 13 was blinking, but now the case is not the same.
I tried to compile and load (through the program port) the same BLINK program as it is described in "Arduino DUE - 1st Look" youtube video.
2) With me, the test not pass neither before my attempts to reload compiled by me program, neither after that.
3) During my attempt to flash my program (i.e. blink.ino) the programming LEDS on the board (RX/TX next to programming port) don't blink
4) The Arduino IDE messages during programming seems OK (nevertheless  of not blinking RX/TX LEDS on the board): Here are the messages:
Code:
Sketch uses 10 076 bytes (1%) of program storage space. Maximum is 524 288 bytes.
Erase flash
Write 10156 bytes to flash

[                              ] 0% (0/40 pages)
[=======                       ] 25% (10/40 pages)
[===============               ] 50% (20/40 pages)
[======================        ] 75% (30/40 pages)
[==============================] 100% (40/40 pages)
Verify 10156 bytes of flash

[                              ] 0% (0/40 pages)
[=======                       ] 25% (10/40 pages)
[===============               ] 50% (20/40 pages)
[======================        ] 75% (30/40 pages)
[==============================] 100% (40/40 pages)
Verify successful
Set boot flash true
CPU reset.
********************************************************************************
But it not works (does not blink yellow onboard LED - connected to pin 13 )!
My board is not OK.
5) I wonder, if the missing or faulty bootloader may be a possible cause.
6) I have working Arduino Mega2560 and may try to use it as a programmer to reburn the Due board bootloader.

What is your opinion if you have such experience?
7) Unfortunately I have not any experience with bootloaders.
I red "Using an Arduino as an AVR ISP (In-System Programmer)" : http://arduino.cc/en/Tutorial/ArduinoISP
and "Upgrading the firmware of the Arduino Due Programming port 16U2"  :http://arduino.cc/en/Hacking/Upgrading16U2Due
I am not sure that this is valid for Arduino Due.
I wont to do all possible, before unpleasant eBay returning procedure .

Please excuse my English.
Any help will be appreciated.
Thanks in advance.
Marin
Logged

Cheltenham, Gloucs, UK
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

There is a fault with the documentation of the Due board.
R23 which is used in the reset circuit is set at 10k which is too high, it should be 1k.
Because of this fault the reset does not take place. Pressing the RESET switch after you have loaded your sketch may get things going for you. My Due suffers from the same problem.
See http://forum.arduino.cc//index.php?topic=167492.0
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you. I have tried the Reset button without result.
I think a key problem  is:
During my attempts to flash any program (i.e. blink.ino) the programming LEDS on the board (RX/TX next to programming port) don't blink.
Logged

Venezuela
Offline Offline
God Member
*****
Karma: 16
Posts: 511
Ground, ground, always ground
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello raikovm,
I am curious about which Due's USB port you are using. Is it the native or the programming port (the one closest to the DC power jack)? I also would like to know the brand/seller of your Due. Is it the original Italian board? It is not strange to see third-party Due based boards with different 'eagles' from the original Italian one. Regards!
Logged

Laguna Hills, CA 92653
Offline Offline
Full Member
***
Karma: 0
Posts: 112
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What board have you selected in 1.5.4?
Logged

Cheers, Gary
Due for controlling Electric car charging.
Nissan LEAF - Mini Quick Charge (mQC)

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@Palliser
My board is from eBay (other customers don't have problems):
http://www.ebay.com/itm/111124867861?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

@garygid
I use Programming port and I set an Board option: "Arduino Due (Programming Port)" and тхе Com port, what is the Windows Device Manager: Arduino Due Programming Port (COM3)

If I try to connect Arduino Due to the native port it is not recognized by Windows.
Logged

Laguna Hills, CA 92653
Offline Offline
Full Member
***
Karma: 0
Posts: 112
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Apparently this is a China-duino Due-like device.
It says produced from the schematics... but the
"official" schematic has errors in it, right?

Possibly you are doing the Quality Control testing?

Is the 32 kHz crystal for the RTC missing from the board?

Do you have other boards to try?
Logged

Cheers, Gary
Due for controlling Electric car charging.
Nissan LEAF - Mini Quick Charge (mQC)

Pages: [1]   Go Up
Jump to: