Go Down

Topic: [Solved] Driver issue windows 7 (Read 1 time) previous topic - next topic

bakkerl

Oct 21, 2013, 12:47 pm Last Edit: Oct 24, 2013, 10:04 am by bakkerl Reason: 1
Hello,

I have some issues on my windows 7 64bit machine.

I have a Arduino nano which is working fine on a Windows XP machine. I can upload sketches and the loopback test as described at http://forum.arduino.cc//index.php?topic=73748.0 is working.

The same nano, the same USB cable, only now on my Windows 7 machine, is failing on me.
- The loopback test fails; The RX and TX leds are blinking when pressing keys on my keyboard in the terminal application. Only no feedback is displayed in the terminal application.
- Uploading is failing with the (not so famous): avrdude: stk500_getsync(): not in sync: resp=0x00
(full output below)

Looks like my windows 7 don't want to receive any data back...

Driver info on the windows7 system (installed from the windows update):
Driver Date: 12-7-2013
Driver Version: 2.8.30.0
Digital Signer: Microsoft Windows Hardware Compatibility Publisher

Where did i go wrong?


Code: [Select]

Binary sketch size: 2,596 bytes (of a 30,720 byte maximum)
C:\Program Files (x86)\Arduino\hardware/tools/avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P\\.\COM10 -b57600 -D -Uflash:w:C:\Users\bakkerl\AppData\Local\Temp\build7726205471105300514.tmp\AnalogReadSerial.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2009 Joerg Wunsch

        System wide configuration file is "C:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf"

        Using Port                    : \\.\COM10
        Using Programmer              : arduino
        Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

bakkerl

A downgrade of the driver solved my issue.

From 2.8.30.0 to 2.8.24.0 ( http://www.ftdichip.com/Drivers/CDM/CDM20824_Setup.exe )

lalmat


64bit

#3
Oct 30, 2013, 05:59 pm Last Edit: Oct 30, 2013, 06:11 pm by 64bit Reason: 1
This worked for me as well on Windows Vista and Windows 8 for the Nano. Make this post sticky!!!

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy