Go Down

Topic: Arduino Mega2560 USB connection not working (Read 278 times) previous topic - next topic

RonyA

I was working on my robot the other day and after 2 hours of uploading and testing new code, the comm port suddenly died out. I unplugged and plugged the cable back in. I reinstalled the drivers. I tried to plug the arduino into other computers. I tried with different cables. It still won't work. A USB cable will power the device, but nothing else.

The arduino itself is still operable.  It sends out PWM signals and follows the flawed logic I uploaded the last time, but it won't be recognized  as a device on any computer. This leads me to believe the USB connection is the problem. Either the hardware itself or the driver on the device.  I have asked many people, but they have not been able to help me fix this problem.

Is there anything I can do to fix this? I know the processor and the peripherals still work, but the communication with a computer is not working.

K5CZ

There are many similar threads, try to find inspiration in these (for example):
http://forum.arduino.cc/index.php/topic,178994.0.html
http://forum.arduino.cc//index.php/topic,191873.0.html
http://forum.arduino.cc//index.php?topic=191983.0.html
Arduino Uno R3, Arduino Mega 2560 R3, Ethermega (R3), and some Ethernet Shields (R3), Chronodots, TMP36 sensors, DS18B20 sensors, LCDs/TFTs, RS232C to learn and play...

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy