Go Down

Topic: Problem with upload from Mac OS 10.9 through Programming Port of Due (Read 4214 times) previous topic - next topic

Danoino

Problem: When trying to upload a sketch via the USB Programming Port the following error message appears:

Code: [Select]
No device found on /dev/tty.usbmodem1421

However, when I connect the Arduino via the Native USB Port the sketch is uploaded and runs just fine.
To my understanding, I have selected the Board and the Port correctly each time.

I am using an Arduino Due, Arduino IDE 1.5.4 and Mac OS 10.9 (Mavericks).

The same problem has been described by "aude" here:
http://forum.arduino.cc//index.php?topic=148613.msg1442629#msg1442629
In his case the problem was solved setting the Baud rate manually.
Would the problem in my case also be the Baud rate? If yes, how do I change it on a Mac?
Is that an Arduino IDE software bug or is it meant to be that way?

I would be very happy about any help.

piershaw

#1
Oct 27, 2013, 02:58 am Last Edit: Oct 27, 2013, 03:05 am by piershaw Reason: 1
I have the same problem after updated to os x maverick tty.usbmodem are all gone! :(

piershaw

I got it working I just unplued all connections to the board and downloaded the FTDI files off the website and its all working again

Danoino

piershaw, that sounds very good! Could you explain to me where exactly I can find these FTDI files and what I have to do with them? I thought there are no drivers to be installed for Mac OS. ?
I saw that the FTDI files are mentioned in the Windows installation instructions, but on the Mac I can't see any Arduino folder with such files.

Danoino

I tried to do the same as you, piershaw, but it did not work for me.
I did the following:
1. Download FTDI driver version 2.2.18 for Mac from http://www.ftdichip.com/Drivers/VCP.htm
2. Install FTDIUSBSerialDriver_10_4_10_5_10_6_10_7.mpkg
3. Restart Computer
4. Connect Arduino Duo Board via Programming Port to the Mac.
5. Open Arduino IDE 1.5.4
6. Set the Board to Arduino Due (Programming Port)
7. Set the Port to /dev/tty.usbmodem1411
8. Upload the example sketch "Blink"

Again the error message was:
Code: [Select]
No device found on tty.usbmodem1411

What might I be doing wrong? :smiley-sad-blue:

Danoino

I just read that FTDI drivers might not at all be the reason for my problem:

http://forum.arduino.cc/index.php?topic=140999.0

Quote
Well, Due doesn't use an FTDI chip, so that won't help any.  The driver for the 16u2 chip used instead SHOULD be built into the Mac.  (it would show as /dev/usbmodem* instead of /dev/usbserial*, but that shouldn't fool the Arduino menu.)  When you say "programming port", you mean the one closest to the power jack, right?


So should the problem be related to the 16u2 driver?
However, I have no problem finding and selecting the /dev/tty.usbmodem1411 in the Ports menu in the Arduino IDE.
This issue is really causing me headaches.  :~

Go Up