Pages: [1]   Go Down
Author Topic: [Resolu] Arduino UNO non reconnu  (Read 446 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

bonjour,

lorsque que je connecte mon Arduino UNO, la diode 13 clignote, mais dans l'interface ide, la ligne "port série" est grisée, impossible d'uploader
je me suis ajouté aux utilisateur, je lance arduino en admin, je redémarre en le lassant braché, mais toujours pareil

si ca peut aider, j'ai
Code:
hj@hj-ThinkPad-L530:~$ dmesg|tail
[ 2809.986708] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 2820.783878] psmouse serio1: Touchpad at isa0060/serio1/input0 - driver resynced.
[ 3398.599769] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3398.614745] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3398.629651] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3398.658240] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3445.950618] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3445.950626] psmouse serio1: issuing reconnect request
[ 3446.494949] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3458.954720] psmouse serio1: Touchpad at isa0060/serio1/input0 - driver resynced.

A noter que j'ai le meme probleme sous windows (meme PC en dual boot), j'ai essayé d'installer les drivers usb3 au cas ou, mais rien.
les clé usb et disques durs marchent bien par contre


Pouvez-vous m'aider svp

Merci
« Last Edit: November 03, 2013, 06:32:24 am by bryan2 » Logged

IDF/SO
Offline Offline
Edison Member
*
Karma: 41
Posts: 2306
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Est-ce qu'il a déjà été reconnu  auparavent ?

J'ai eu un problème équivalent avec une UNO R2 dont un nombre important d'exemplaires ont été vendus buggés.
Ils n'étaient reconnus ni sous Linux ni sous Win7 et peut-être Vista.
J'ai du reflasher l'ATMga 8u2.
Logged

Offline Offline
Faraday Member
**
Karma: 34
Posts: 5213
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

bonjour,

lorsque que je connecte mon Arduino UNO, la diode 13 clignote, mais dans l'interface ide, la ligne "port série" est grisée, impossible d'uploader
je me suis ajouté aux utilisateur, je lance arduino en admin, je redémarre en le lassant braché, mais toujours pareil

si ca peut aider, j'ai
Code:
hj@hj-ThinkPad-L530:~$ dmesg|tail
[ 2809.986708] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 2820.783878] psmouse serio1: Touchpad at isa0060/serio1/input0 - driver resynced.
[ 3398.599769] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3398.614745] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3398.629651] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3398.658240] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3445.950618] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3445.950626] psmouse serio1: issuing reconnect request
[ 3446.494949] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 3458.954720] psmouse serio1: Touchpad at isa0060/serio1/input0 - driver resynced.

A noter que j'ai le meme probleme sous windows (meme PC en dual boot), j'ai essayé d'installer les drivers usb3 au cas ou, mais rien.
les clé usb et disques durs marchent bien par contre


Pouvez-vous m'aider svp

Merci

bonjour
le uno à déjà été connecté (vu et reconnu)  ou jamais sue le PC ?
les erreurs listée sont recupérées à quel moment ?

Je trouve le psmouse touchpad etonnant là concernant un arduino
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

bonjour,

Merci de votre interet,

oui, l'arduino a été reconnu et programmé, il fonctionne tous les jours  smiley Mais je l'ai fais avec un autre PC,
le probleme survient avec 2 autres PC que j'ai ici
Logged

IDF/SO
Offline Offline
Edison Member
*
Karma: 41
Posts: 2306
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Faudrait en dire plus sur tes PC nous n'avons pas de boule de cristal.
Quels systemes d'exploitation ?

Ton problème est peut -être différent du mien, mais le mien  ne se produisait pas avec XP seulement avec Linux. et Win7.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Les pc avec lesquelles j'ai les probleme sont un Ubuntu et un win7. Je sais qu'avec XP ca marchait et sur mon autre PC avec ubuntu ca marchait aussi il me semble.
j'essayerai avec un XP pour voir...
Logged

France
Offline Offline
Faraday Member
**
Karma: 40
Posts: 3634
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sous Linux
Tu peux faire un lsusb pour voir si la carte est bien identifiée

Le résultat du dmesg que tu as mis dans tn post ne semble pas se rapporter à ta carte arduino.
Il faut:
   déconnecter la carte arduino
   attendre 10 secondes
   reconnecter la carte
   faire dmesg | tail
Là tu devrais voir la connexion de ta carte si elle était bien reconnue par le lsub
Logged

IDF/SO
Offline Offline
Edison Member
*
Karma: 41
Posts: 2306
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Un
$lsusb
est aussi utile
exemple chez moi actuellement
b@zeus:$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 046d:c03f Logitech, Inc. M-BT85 [UltraX Optical Mouse]
Bus 001 Device 002: ID 046d:c312 Logitech, Inc. DeLuxe 250 Keyboard
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
b@zeus:$
Après avoir raccordé un UNO :
b@zeus:$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 046d:c03f Logitech, Inc. M-BT85 [UltraX Optical Mouse]
Bus 001 Device 002: ID 046d:c312 Logitech, Inc. DeLuxe 250 Keyboard
Bus 001 Device 004: ID 2341:0001 Arduino SA Uno (CDC ACM)
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
b@zeus:$

Edit il y a aussi $ls /dev/tty* où dans les résultats tu dois trouver un /dev/ttyACM0

« Last Edit: November 02, 2013, 04:18:25 pm by 68tjs » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Vous etes synchro les gars  smiley

voici pour le lsusb:

Code:
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 046d:c068 Logitech, Inc. G500 Laser Mouse
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 03f0:0024 Hewlett-Packard KU-0316 Keyboard
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 010 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

et

Code:
bryan@bryan-pc-fixe:~$ ls /dev/tty*
/dev/tty    /dev/tty23  /dev/tty39  /dev/tty54      /dev/ttyS10  /dev/ttyS26
/dev/tty0   /dev/tty24  /dev/tty4   /dev/tty55      /dev/ttyS11  /dev/ttyS27
/dev/tty1   /dev/tty25  /dev/tty40  /dev/tty56      /dev/ttyS12  /dev/ttyS28
/dev/tty10  /dev/tty26  /dev/tty41  /dev/tty57      /dev/ttyS13  /dev/ttyS29
/dev/tty11  /dev/tty27  /dev/tty42  /dev/tty58      /dev/ttyS14  /dev/ttyS3
/dev/tty12  /dev/tty28  /dev/tty43  /dev/tty59      /dev/ttyS15  /dev/ttyS30
/dev/tty13  /dev/tty29  /dev/tty44  /dev/tty6       /dev/ttyS16  /dev/ttyS31
/dev/tty14  /dev/tty3   /dev/tty45  /dev/tty60      /dev/ttyS17  /dev/ttyS4
/dev/tty15  /dev/tty30  /dev/tty46  /dev/tty61      /dev/ttyS18  /dev/ttyS5
/dev/tty16  /dev/tty31  /dev/tty47  /dev/tty62      /dev/ttyS19  /dev/ttyS6
/dev/tty17  /dev/tty32  /dev/tty48  /dev/tty63      /dev/ttyS2   /dev/ttyS7
/dev/tty18  /dev/tty33  /dev/tty49  /dev/tty7       /dev/ttyS20  /dev/ttyS8
/dev/tty19  /dev/tty34  /dev/tty5   /dev/tty8       /dev/ttyS21  /dev/ttyS9
/dev/tty2   /dev/tty35  /dev/tty50  /dev/tty9       /dev/ttyS22
/dev/tty20  /dev/tty36  /dev/tty51  /dev/ttyprintk  /dev/ttyS23
/dev/tty21  /dev/tty37  /dev/tty52  /dev/ttyS0      /dev/ttyS24
/dev/tty22  /dev/tty38  /dev/tty53  /dev/ttyS1      /dev/ttyS25

sous XP, ca marche
Logged

IDF/SO
Offline Offline
Edison Member
*
Karma: 41
Posts: 2306
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ta carte c'est une R1, une R2 ou une R3 ?
C'est marqué au verso.

Si c'est une R2 et d'aprés ce que tu décris : marche sur XP, ne marche pas sous Windows Seven ni sous Linux cela sent la version buggée de l'USB surR2.
Voir le (vieux) fil :
http://forum.arduino.cc//index.php?topic=71619.msg536018#msg536018
Logged

France
Offline Offline
Faraday Member
**
Karma: 40
Posts: 3634
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Vous etes synchro les gars  smiley

voici pour le lsusb:

Code:
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 046d:c068 Logitech, Inc. G500 Laser Mouse
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 03f0:0024 Hewlett-Packard KU-0316 Keyboard
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 010 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Comme tu peux le voir, le lsusb ne retourne rien concernant ta carte. Donc elle n'est pas reconnue par l'OS. Ce qui milite pour la proposition de 68tjs de vérifier si la carte est programmée avec la bonne version du firmware pour le circuit d'interface USB.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci beaucoup pour votre aide

l'arduino en question est dans un boitier avec un shield et autre potentiometres, il est assez délicat à démonter. Je ne saurais pas dire si c'est un R2, mais je l'ai acheté aux environs de 2011, donc tres probablement. Pas d'info sur la petite boite en carton (que j'ai toujours) si ce n'est un code barre avec le numero 00659678.
Etant donné que j'ai au final une solution pour le programmer (avec mon vieux PC sous XP), je ne vais pas faire la manip car comme je disais, il est délicat à démonter, et en cas de probleme, je suis dans la m... car j'en ai besoin au quotidien

Merci encore pour votre aide, de toute facon, je vais bientôt acheter une autre board pour un autre projet, donc je serai fixé

pour info, le projet dont il est question ici est:
http://forum.histomobile.com/viewtopic.php?f=33&t=1259
PS: sur les photos, on voit un Leonardo, mais comme il a grillé, je l'avais remplacé par un UNO
« Last Edit: November 03, 2013, 06:34:46 am by bryan2 » Logged

Pages: [1]   Go Up
Jump to: