Go Down

Topic: LCD stopped working, not sure how to troubleshoot (Read 465 times) previous topic - next topic

Lxypi

I have a Sunfounder Arduino Uno R3 board and several Hitachi-compatible LCD modules (some were included as a kit, some I scavenged off of other gear).  I was working on a project to display/scroll stuff and was having a blast programming the LCD.

At some point in my build process, I dropped the unit (LCD, Arduino, breadboard) off the table.  Since then, I can't make any of my assorted LCDs display any text.

I tested every output of the Arduino board (digital and analog), the Arduino seems to be functioning normally.  I can still get backlight on the LCD panels.  Given this circuit and code:
http://arduino.cc/en/Tutorial/LiquidCrystalAutoscroll

I am unable to see any output on the display.  Turning the VR left or right doesn't produce a change in contrast like it did initially.  This occurs on all my Hitachi-compatible modules, not just the one I dropped.  I'm at a loss how to troubleshoot the panel.

I suspect one of three things:
Something is wrong with the Arduino (unlikely, I checked all the outputs with LEDs)
Something is wrong with my display (unlikely, I have three of them with the same symptom)
Something is wrong with the breadboard or my wiring (most likely)

So, in this case, how do I begin troubleshooting?  I suspect I could omit the data pins as a test and get SOME sort of output by supplying the correct voltage somewhere.  Any help is appreciated.

Thanks,
Brian

MAS3

#1
Nov 04, 2013, 12:59 am Last Edit: Nov 04, 2013, 01:02 am by MAS3 Reason: 1
Hi Brian.

So you've had some fun, and now the learning part starts  ;)

You're telling you think the breadboard / connections is most likely to be wrong.
An Uno and a 1602 like display isn't a very complicated thing to build.
So maybe best would be to simply tear down your build and start from scratch.

Apart from the backlight, nothing happens at all with your display ?
Do you have a potmeter wired up ?
If so, what happens if you turn that (something should happen).
In case nothing happens, recheck the potmeter's wiring.
If the wiring is good, the display doesn't react to the potmeter and you do not have a multimeter, use the Uno to test the potmeter.
Connect the center pin of the potmeter to an analog input and a LED to an output.
Load a sketch that has the LED vary brightness relative to the input from the potmeter to confirm the potmeter still works.

If you still can't get things going:
- Make a clear photograph of you setup and upload it in this thread.
- Make sure the wires you used are visible and can be visually traced from the photograph.
- Show your code (and don't forget to put that in code tags).
- Tell everything you already tried.

Edit: corrected typo's
Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Paul__B

Are you using pre-made "jumper" wires that have a plastic moulding over the base of the pins?

Test each of these with a multimeter  -  or simply use them to wire to a LED on the breadboard with a 330 ohm resistor in series from the Arduino Vcc and ground.  My bet is that one of them has pulled loose within that little black plastic moulding.

And of course, tear down the breadboard and wire it again if you have not already done so in the process of testing the wires.

Lxypi

Thanks for all the help!

I was able to get it working again just by being slow and methodical.  One pin at a time, using the VOM to check resistance and voltage at every step.   I connected up Vcc, Vss, and Vo on the display, with the pot, as shown in the diagram.  After checking each connection with the VOM, I was finally able to adjust the contrast (which is what clued me in that something wasn't working on the first go round).

After that, I finished wiring up the rest of the pins and viola, the autoscroll code runs beautifully again.

My guess is that either a jumper or a breadboard pin wasn't making full contact.  If I had poked around the first time with the VOM, I probably would have found that right away.

Thanks again for all the help!!
Brian

Go Up