Pages: [1]   Go Down
Author Topic: Is the display broken?  (Read 282 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 72
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi there,

I've got a problem with a 2x16 display. I connected it to Arduino and mixed up the ground and the poweer supply forr the backlight. After I connected it to my PC it only displayed white boxes in the first line. It's a 5V display. The code I'm using with it is:
Code:
/*
  LiquidCrystal Library - Hello World
 
 Demonstrates the use a 16x2 LCD display.  The LiquidCrystal
 library works with all LCD displays that are compatible with the
 Hitachi HD44780 driver. There are many of them out there, and you
 can usually tell them by the 16-pin interface.
 
 This sketch prints "Hello World!" to the LCD
 and shows the time.
 
  The circuit:
 * LCD RS pin to digital pin 6
 * LCD Enable pin to digi
 LCD Enable pin to digital pin 9
 * LCD D4 pin to digital pin 5
 * LCD D5 pin to digital pin 1
 * LCD D6 pin to digital pin 3
 * LCD D7 pin to digital pin 0
 * LCD R/W pin to ground
 * 10K resistor:
 * ends to +5V and ground
 * wiper to LCD VO pin (pin 3)
 
 Library originally added 18 Apr 2008
 by David A. Mellis
 library modified 5 Jul 2009
 by Limor Fried (http://www.ladyada.net)
 example added 9 Jul 2009
 by Tom Igoe
 modified 22 Nov 2010
 by Tom Igoe
 
 This example code is in the public domain.

 http://www.arduino.cc/en/Tutorial/LiquidCrystal
 */

// include the library code:
#include <LiquidCrystal.h>

// initialize the library with the numbers of the interface pins
LiquidCrystal lcd(6, 9, 5, 1, 3, 0);

void setup() {
  // set up the LCD's number of columns and rows:
  lcd.begin(16, 2);
  // Print a message to the LCD.
  lcd.print("hello, world!");
}

void loop() {
  // set the cursor to column 0, line 1
  // (note: line 1 is the second row, since counting begins with 0):
  lcd.setCursor(0, 1);
  // print the number of seconds since reset:
  lcd.print(millis()/1000);
}

Is the display broken now?

Thanks in advance.
arduino2013
Logged

Western New York, USA
Offline Offline
Faraday Member
**
Karma: 37
Posts: 4329
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The display and the backlight are two separate items so your display is probably still good although your backlight may not be.

You may be having a problem since you are using pins 0 and 1 for two of your LCD data lines and those two pins are also used for the serial connection with which you download your sketch.   The LCD could be messing up the download and/or the serial circuitry could be messing up your LCD.


Don
Logged

NSW Australia
Offline Offline
Faraday Member
**
Karma: 88
Posts: 3564
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The backlight should be quite immune to being connected in reverse at only 5V.

White boxes on the first row is the power-up default - it means you have the contrast control set approximately correct, but are not yet communicating with the display.
Logged

Pages: [1]   Go Up
Jump to: