Pages: [1]   Go Down
Author Topic: vista and arduino  (Read 700 times)
0 Members and 1 Guest are viewing this topic.
malmö / berlin
Offline Offline
Jr. Member
**
Karma: 0
Posts: 58
fhp>--vs--<k3
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

hej,

i was trying to install arduino007 on windows vista , but the arduino starts already complaning when i try to compile code, it says:

avr-gcc: _spawnvp: No such file or directory

Couldn't determine program size:
/cygdrive/c/arduino-0007/tools/avr/bin/avr-size:
'C:\Users\Sabine\AppData\Local\Temp\build57178.tmp\sketch_070514a.hex':
No such file

 did some one of you have an idea what to do,

i found just one old post about problems with winavr and vista in the arduino forum, but there wassn't any solution to solv this problem,... so maybe now some one have a clue,

thx
tomek
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey, there's a suggested fix here: http://www.madwizard.org/extern/winavr-vista/.  Can you give it a shot and see if it fixes the problem?  If so, I can include the updated files with Arduino 0008.
Logged

malmö / berlin
Offline Offline
Jr. Member
**
Karma: 0
Posts: 58
fhp>--vs--<k3
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

hej,

i'm not so shure how to do it, should I just replace the "avr-gcc.exe" in the tools/avr/bin folder but where to place the "msys-1.0.dll s" ??

or did i have to install winavr (but how to contact this to the arduinoprogramm) ?


thx
tomek
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I have the same problem, and also I can't fix it with the patch (I've even tried copying the WinAVR files to the Tools map of the Arduino software, but with no result).

Can a solution be found quickly? My new laptop came with Windows Vista and it's kinda awkard that I can't run Arduino with it (yet).

Thanks in advance to anyone trying to solve this problem!
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The new version of winarv (20070525) fix the problems with windows vista: only replace the folder tools\avr\ with the new version and have fun...
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Alright, this works! Thanks a lot...!
Logged

malmö / berlin
Offline Offline
Jr. Member
**
Karma: 0
Posts: 58
fhp>--vs--<k3
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


hej,

it works now also for me with the avr, thx

but we got a new problem with the java when we try to upload the program to the arduino:


java.io.IOException: CreateProcess: C:\Users\Sabine\Desktop\arduino-0008\tools/avr/bin/uisp -dpart=atmega168 -dprog=stk500 -dserial=/dev/com4 -dspeed=19200 --upload if=C:\Users\Sabine\Desktop\arduino-0008\examples\Digital\Blink\applet\Blink.hex error=2

      at java.lang.Win32Process.create(Native Method)

      at java.lang.Win32Process.<init>(Unknown Source)

      at java.lang.Runtime.execInternal(Native Method)

      at java.lang.Runtime.exec(Unknown Source)

      at java.lang.Runtime.exec(Unknown Source)

      at java.lang.Runtime.exec(Unknown Source)

      at processing.app.Uploader.uisp(Uploader.java:172)

      at processing.app.Uploader.uploadUsingPreferences(Uploader.java:78)

      at processing.app.Sketch.upload(Sketch.java:1693)

      at processing.app.Sketch.exportApplet(Sketch.java:1755)

      at processing.app.Editor$40.run(Editor.java:1902)

      at java.awt.event.InvocationEvent.dispatch(Unknown Source)

      at java.awt.EventQueue.dispatchEvent(Unknown Source)

      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

      at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

      at java.awt.EventDispatchThread.run(Unknown Source)
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

My guess is that it's because of the forward slashes in the command (they probably should be backslashes).  It works on previous versions of Windows, but probably isn't the right way to be doing things.  I can try to build a new version of pde.jar that uses the appropriate slashes, but not until later today.  If you need it sooner than that, you could try checking the code out of subversion and making the change yourself.  
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Whoops, never mind.

I think WinAVR probably doesn't include uisp.  Try copying the one from the Arduino distribution to that location (C:\Users\Sabine\Desktop\arduino-0008\tools/avr/bin/), and see if it works.
Logged

Pages: [1]   Go Up
Jump to: