Pages: [1] 2 3   Go Down
Author Topic: AC dimmer 220 problemi vari ed eventuali...  (Read 1744 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 53
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salve a tutti

Come dice il titolo ho bisogno di aiuto per la costruzione di una board che possa agire da dimmer per una lampada. Ho seguito scrupolosamente le istruzioni fornite in questo sito: http://www.instructables.com/id/Arduino-controlled-light-dimmer-The-circuit/?ALLSTEPS compreso il debugging alla fine...ma non c'è via di uscita...

il mio circuito è quello illustrato in foto allegata.

Il codice è quello presente sul sito...

Potreste aiutarmi a capire cosa c'è che non và? Se postate del codice che potrebbe aiutarmi a testare le varie parti del circuito ed individuare dove sono i problemi ve ne sarei molto grato. I pin di arduino usati sono descritti in foto.

Come info aggiuntive vi dico che il led prima del moc non si accende e che disconnettendo dei fili a caso del moc  3021 la luce rimane accesa a metà intensità...

Grazie mille dell'eventuale aiuto! Chiedete pure se necessitate di aiuto per aiutarmi...
Saluti
David



* foto.JPG (153.29 KB, 960x720 - viewed 103 times.)
Logged

BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21859
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Posso subito dire che non funziona con tutte le utenze differenti da una lampadina da segnalazione al neon (Non intendo tubi flurescenti al mercurio a bassa pressione).

Quote
Ho seguito scrupolosamente le istruzioni fornite in questo sito: http://www.instructables.com/id/Arduino-controlled-light-dimmer-The-circuit/?ALLSTEPS
Non mi risulta che hai seguito scrupolosamentele istruzioni. Se questo é il modo di seguire scrupolosamente le istruzioni Ti devo dire per l'incolumnitá Tua e di terzi che é meglio che lasci stare circuiti a 230V. È troppo pericoloso.

Prendi l' alimentazione del carico dopo la resistenza da 27kOhm.
Con una resistenza da 10kOhm tra uscita Arduino e MOC3021 non riesci ad accendere il LED del MOC3021.
Di che colore é il LED in serie al MOC o hai messo un diodo?
Il circuito che vuoi aver seguito ha una resistenza da 1kOhm sul gate del Triac.
Hai usato lo sketch con le impostazioni per 50Hz?

Ciao  Uwe
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 53
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Grazie per la prontezza...

Si il mio scrupolossamente intenedeva dire che ho mixato parte delle informazioni con un altro topic letto sul forum...

Detto ciò non capisco alcune delle tue informazioni:
- Prendi l' alimentazione del carico dopo la resistenza da 27kOhm: troppo? troppo poco o semplicemente diverso?
-Con una resistenza da 10kOhm tra uscita Arduino e MOC3021 non riesci ad accendere il LED del MOC3021: si è vero ho infatti rimpiazzato la resistenza e il led si accendeva. Su un post ho trovato che però stavo rischiando l incolumità del mio MOC...e quindi sono tornato indietro...
-Di che colore é il LED in serie al MOC o hai messo un diodo? è verde...non sapevo che facesse la differenza...
-Il circuito che vuoi aver seguito ha una resistenza da 1kOhm sul gate del Triac. : si l'ho messa ma ho dimenticato di trascriverla nel progetto...ops...
Hai usato lo sketch con le impostazioni per 50Hz? si è quello postato sul sito.
Posso subito dire che non funziona con tutte le utenze differenti da una lampadina da segnalazione al neon (Non intendo tubi flurescenti al mercurio a bassa pressione): non sò cosa sia la lampada al neon di segnalazione... io cerco di accendere una lampadina a filamento da 100W...

Cosa posso controllare ancora? Non pensi che il circuito sia adeguato?Devo sostituire dei componenti? Potresti suggerirmene uno funzionante? Potresti aiutarmi a fare del debugging?

Grazie mille per l'aiuto che mi date lo apprezzo davvero...e scusate la raffica di domande alla fine ma ci tengo davvero a capire come realizzare questa cosa...

Grazie ancora e scusate l'ignoranza ma questo è l unico modo che conosco per imparare...se avete suggerimenti per ovviare alla necessità di chiedere sul forum sono accetti di buon grado!

A presto

David





Logged

BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21859
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si il mio scrupolossamente intenedeva dire che ho mixato parte delle informazioni con un altro topic letto sul forum...
non ho parole....

Quote from: Turbodede
- Prendi l' alimentazione del carico dopo la resistenza da 27kOhm: troppo? troppo poco o semplicemente diverso?
Come pensi che possono passare qualche ampere attraverso una resistenza da 27kOhm a 230V?????
Semplicemente sbagliato devi prendere i 230V prima della resistenza.

Quote from: Turbodede
Cosa posso controllare ancora? Non pensi che il circuito sia adeguato?Devo sostituire dei componenti? Potresti suggerirmene uno funzionante? Potresti aiutarmi a fare del debugging?

Grazie mille per l'aiuto che mi date lo apprezzo davvero...e scusate la raffica di domande alla fine ma ci tengo davvero a capire come realizzare questa cosa...

Grazie ancora e scusate l'ignoranza ma questo è l unico modo che conosco per imparare...se avete suggerimenti per ovviare alla necessità di chiedere sul forum sono accetti di buon grado!

A presto David

Un consiglio da buon amico: Lascia stare lavorare con 230V. Non hai le conoscenze adeguate per questo.
Ciao Uwe
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 53
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Grazie per la risposta e del consiglio ma per il momento mi ritengo sufficientemente sicuro a continuare.

Quote
Come pensi che possono passare qualche ampere attraverso una resistenza da 27kOhm a 230V?????
Semplicemente sbagliato devi prendere i 230V prima della resistenza.

Tecnicamente dovrebbero passare ben 7 mA...ma non sò se sono sufficienti per pilotare una lampada...da quanto mi fai capire no... però non capisco a questo punto perchè sul sito che ti ho mostrato prima le resistenze sono addirittura da 30KOhm...tecnicamente per seguire il tuo consiglio dovrei semplicemente eliminare le due resistenze vero?

Quote
Un consiglio da buon amico: Lascia stare lavorare con 230V. Non hai le conoscenze adeguate per questo.
Ciao Uwe

Si credo di non avere le conoscenze adeguate...ma credo anche che possiamo lavorare su questo punto... io penso che con l aiuto di un "esperto" io possa essere in grado di costruire un circuito passo passo...magari a piccoli passi e capire in dettaglio tutto...io credo che questo sia lo scopo del forum alla fine...

Possiamo fare prove, esercizi e potete indicarmi anche dove farmi un pochino di cultura a riguardo. Essendo maggiorenne mi assumo tutta la responsabilità delle mie azioni...

io VOGLIO davvero risolvere questo problema ( e il problema non è il mio giocattolo che non funziona bensì capire come funziona questa cosa...) se vi và da aiutarmi sono disposto a cominciare da capo e seguire scrupolosamente( senza mix stavolta) i vostri insegnamenti...

Se a voi non và lo capisco e aspetterò con pazienza che ci sia qualcuno a cui vada...magari rifaccio un post tra un mese...però... c'è un però...non ditemi che non ho le conoscenze e per questo non posso farci nulla se non lasciare stare perchè non credo sia questa la filosofia su cui si basa questa comunità...

Grazie dei preziosi suggerimenti e a presto...confido in voi...

David
Logged

Italy (Venice)
Offline Offline
Edison Member
*
Karma: 25
Posts: leet
Quello che non c'è non si può rompere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

penso che Uwefed si sia visibilmente urtato nel vedere errore così macroscopici e PERICOLOSI, sottolineo anch'io PERICOLOSI , infatti è veramente difficile non dirtene quattro perchè non sai proprio niente di elettronica , se uno non sà nemmeno la legge di ohm che è la prima cosa che si impara come puoi mettrti a costruire roba che funziona alla tensione di rete?,

 lo sai che se sbagli di collegare un solo pin ti entra dentro l'USB la tensione di rete e puoi dire addio alla scheda arduino, al PC tastiera, monitor etc....? Oltre ad essere pericolosa per tè

hai collegato il pin 5 invece del 6 del MOC, non hai messo la resistenza in serie al gate del triac, sono ENORMI errori , quali errori farai edesso, sei come un bambino che bisogna tenerlo per manina e dirgli tutto quello che deve fare,  sicuramente oltre a me farai urtare la sensibilità anche di altre persone

leggi quà:

http://www.leonardomiliani.com/2013/la-sindrome-di-gundam/

Logged

Switzerland
Offline Offline
Faraday Member
**
Karma: 114
Posts: 5982
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

... e se non ti basta ... prova, con calma, a leggerti tutta QUESTA discussione e ... guarda come è finita !

Magari sarebbe bello evitare che si ripeta ... smiley-wink

Guglielmo
Logged

Search is Your friend ... or I am Your enemy !

Italy (Venice)
Offline Offline
Edison Member
*
Karma: 25
Posts: leet
Quello che non c'è non si può rompere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Turbodede, ho guardato lo schema originale:
http://www.instructables.com/id/Arduino-controlled-light-dimmer-The-circuit/?ALLSTEPS

Lo schema è a posto e funziona,  però tu ricopiandolo hai commesso 4 errori , se li trovi e li cerchi con la penna rossa penso si possa continuare, altrimenti non è possibile, dai fai uno sforz e vediamo se si può procedere con il tuo progetto
Logged

BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21859
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Si credo di non avere le conoscenze adeguate...ma credo anche che possiamo lavorare su questo punto... io penso che con l aiuto di un "esperto" io possa essere in grado di costruire un circuito passo passo...magari a piccoli passi e capire in dettaglio tutto...io credo che questo sia lo scopo del forum alla fine...

Turbodede cosí non funziona. Non sappiamo che errori fai di cui non ci parli. Vuoi costruirti una schedina o come vuoi usare il triac? Anche lí sono parecchie possibilitá di fare errori pericolosi come distanze di sicureza inadeguati e sezioni dei conduttori troppo sottili ecc.

È difficile darti consigli e essere sicuri che farai tutto nel modo giusto e sicuro.
Il Forum serve per aiutare ma chi aiuta deve rendersi conto delle conoscenze dell'altro e di suoi limiti.
Non posso insegnarti via Forum a guidare la macchina se non so se hai la patente. Mi assumo delle responsabilitá anche penali consigliandoti senza essere sicuro che il progetto é alla Ta portata (che in questo momento sembra che non lo sia) .

Sapevi per esempio che il triac consigliato (il TIC206M) ha la aletta di raffreddamento collegato dirattamente con il piedino centrale e percui su di esso trovi i 230V e prendi una stecca se lo tocchi? Ci sono altri modelli di triac dove l'aletta é isolata. Perché non cosigliano uno di quelli?

Ciao Uwe
« Last Edit: November 09, 2013, 04:49:44 pm by uwefed » Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 53
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Grazie a tutti del contributo, davvero...

Appena potrò cercherò di aiutarvi ad aiutarmi e cercare di evidenziare gli errori sul progetto. Ho il primo articolo postato e stò leggendo la conversazione che mi avete postato. Spero questa sera una volta a casa di rimetterci le mani sopra.

Grazie di cuore ancora a tutti e a presto

Saluti

David
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 53
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


Per icio

Allora...oggi ho ricontrollato il circuito...
Più lo guardo e più errori trovo...
Secondo me gli errori sono...:

1 resistenza in serie con il led e il moc 3021 è da 10kohm invece che da 220 ohm;
2 manca una resistenza da 1kohm che collega il terzo piede del Triac (g) al moc 3021;
3 il secondo piede del Triac (a2) è collegato male al moc3021 collegato ad un piede finto(farei bene ad eliminarli forse...)
4 secondo piede del Triac (a2) collegato dopo la resistenza da 27kohm e non prima...

Grazie per la fiducia...e per l aiuto...

Per uwe

Grazie per la dritta e spero che diverrò più bravo ad esternare i miei dubbi in modo che per voi sia più semplice aiutarmi...sono agli inizi...

No non sapevo che a2 e il dissipatore fossero connessi...ma non tocco i componenti della breadboard quando è sotto tensione...ne 220 ne 1 volt...

Per gli altri

Sto continuando a leggere la conversazione mentre ho letto l articolo...grazie per il contributo.

Nuove domande per tutti...

Farei bene a ricominciare da capo il circuito? O correggo gli errori? Cosa tornerebbe più istruttivo?
È corretta l aggiunta della maglia con il condensatore? O farei meglio ad eliminarla?

Grazie di tutto a tutti...
A risentirci

David
Logged

Offline Offline
God Member
*****
Karma: 8
Posts: 691
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

, sei come un bambino che bisogna tenerlo per manina e dirgli tutto quello che deve fare, 


e soprattutto...  se nonostante gli avvisi, un bambino che "continua" con la 220    o con i fornelli del gas   va ... menato    smiley-mad
Logged


Le cose si possono considerare facili in due casi: quando le si conosce bene o quando non le si conosce affatto...

BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21859
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

, sei come un bambino che bisogna tenerlo per manina e dirgli tutto quello che deve fare, 


e soprattutto...  se nonostante gli avvisi, un bambino che "continua" con la 220    o con i fornelli del gas   va ... menato    smiley-mad
Non esagetrare gingardu.
Ognuno é responsabile e ha il permesso di fare i suoi errori. Noi abbiamo avvisato del pericolo e abbiamo sconsiglito.
Ciao Uwe
Logged

Italy (Venice)
Offline Offline
Edison Member
*
Karma: 25
Posts: leet
Quello che non c'è non si può rompere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Bene Turbodede, se correggerai gli errori il tuo circuito funzionerà ed è sicuro smiley
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 53
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ho corretto gli errori ma come ho attaccato la corrente la lampadina si è fulminata senza nemmeno attaccare arduino.

Secondo me devo ricominciare da capo ed evitare per semplificare le cose la maglia aggiunta. Se non vi chiedo troppo potreste darmi una mano nel realizzare la board suddividendola in sotto-circuiti che potrei testare di volta in volta?

E' possibile che alcuni componenti si siano rotti? Magari prima di iniziare dovrei testare l integrità di alcuni di questi...

Grazie mille per le eventuali risposte...

David
Logged

Pages: [1] 2 3   Go Up
Jump to: