Go Down

Topic: Transistor Leakage PLEASE HELP (Read 918 times) previous topic - next topic

surefanatic

Hi, I know this isn't exactly an arduino problem but I'm hoping someone can help me.

I am trying to send a signal to a Ground-switching input module.
(meaning that it triggers high when connected to ground)
and i am trying to have it controlled by a microcrontroller.

to do so i have set up a circuit to one of the output pins of my MC.  

the I/O pin is connected to the base of a NPN transistor.  The Emiter on that transistor is connected to GND.  The Collector is connected to the base of a PNP transistor.  On the PNP transistor the Collector is connected to the input on the "ground switching" module, and the emmitter is connected to a 5 V source.

The Ground switching module trys to draw about 40mA of current, at -24 V with respect to ground.

There are various resistors in between each stage so nothing is directly connected without a resistor in between.

For some reason no matter what the module is always being triggered high, which means it's always being grounded or connected to a more positive source.

I checked the transistors and they are working.   I can't seem to think of a reason why i am getting this leakage.  I think it may have something to do with the fact that when i send nothing from the MC, it leaves the base line on the second transistor (the PNP) floating, which may pick up noise and turn on, but i have a hard time finding documentation to support that.

Can anyone help please



Grumpy_Mike

It is difficult to follow especially the bit about the -24V. But basically the arrangement you have will not work because there is no way that the PNP can ever be turned off.
To turn off a PNP transistor the base has to be within 0.7V of it's emitter and in your arrangement there is nothing to pull it up to that level. A resistor from its base to the +5v line might help.
However, this module you appear to be trying to switch to 5V (although you do say ground all the time) there is no path to ground in your description, only a path to +5. Is the other end connected to +24V or -24v? it is probably the current leaking through this module that is causing you further trouble.
To remove any confusion can you please post a schematic even if it is only hand drawn.

surefanatic

hi thanks for the quick response.

Sorry if this is confusing, I'll add a sketch in a bit.

If I understand what you're saying, you think i am never turning the PNP transistor off.  

I was thinking the same thing, but if thats the case I should register 5 voltes on output to the "ground switching input" line.
When I measure it, I get nothing.

pwillard

This sounds like an IDEAL place to use an opto-isolator.  Have you considered it?

BKnight760

I had a similar problem with a setup I used.  Make sure you have the GND for the power supply you're switching on the transistor connected to the GND for the microcontroller.  Both GND's should be at the same level, otherwise you'll get quite a bit of noise or false switches  on the output of the transistor depending on the voltage difference.

surefanatic

Thanks for all the responses.

I have the same circuit except it's connected to 24V on the output instead of ground.  I switched the input of the module I was connecting to from a "ground-switching input" to a "voltage switching input"

and it works fine.

That being said i do need to figure out whats wrong with grounding circuit.


Boffin1

A high value ( 100k) resistor between base and emitter is always a good idea on a switching transistor so that the transistor doesn't amplify its' own leakage.

Grumpy_Mike

Quote
so that the transistor doesn't amplify its' own leakage.

I think not.
It is a switching transistor, it will not switch until the base voltage exceeds 0.7v. Leakage refers to current not voltage in this context.

Boffin1

but we don't really know what dc path he has on the base, there used to be a saying in the old days " don't forget the base emitter resistor"
I have solved many a bad design problem over the years by fitting the resistor.


Grumpy_Mike

Quote
there used to be a saying in the old days

Yes that was when transistors were made from germanium, nowadays they are made from silicon so that's why no one uses it any more.

Boffin1

LOL   not that far back Mike !   ( Although I am a year younger than the first transistor :-)

There was recently a sound to light box imported from Taiwan, that has diodes from a divider feeding the different silicon driver transistors for the lamps, works fine when its cold, but when it warms up all the lights stay on.
It just needed the resistors...

Go Up