Go Down

Topic: Unable to use Ethernet and SD at the same time on DUE, but on UNO it works fine (Read 568 times) previous topic - next topic

nakedsensor

I found a set of tutorials including this one at http://startingelectronics.com/tutorials/arduino/ethernet-shield-web-server-tutorial/SD-card-web-server/ and loaded it straight into a UNO, where it worked fine with a genuine Arduino Ethernet shield. If I load exactly the same code into a DUE, it does not work.

I tried adding some serial strings to help debug, and it looks like it runs the 'setup' routine fine, and starts the 'loop' routine ... but it never detects a client calling into it, so never replies.

Any ideas ?

Palliser

Hello nakedsensor,
UNO and DUE have different micro-controllers (AVR and SAM3X), thus, internally they work also differentlyand use different libraries. Please, look at the following thread.

  http://forum.arduino.cc/index.php?PHPSESSID=i72gnopc96nc0rehg2698fphg1&topic=189348.msg1402905#msg1402905

There, in my reply #7 you will find a code that works OK for a DUE and an Ethernet shield. Good luck!
-P

nakedsensor

Thanks Palliser !

I may stick with the UNO for this project anyway, but at least I understand that it is not my fault !

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy