Go Down

Topic: what about ClearType BUG !? Why is it not getting fixed? (Read 3049 times) previous topic - next topic

smilem

I use latest Arduino IDE. What about ClearType BUG !? Why is it not getting fixed?

I'm using WinXP SP3, and using "standard" is not an option as it does not work for desktop, and some other windows UI components. You can't customize it either. Other JAVA software works fine so this is clearly Arduino IDE bug, an old bug.


CrossRoads

Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

smilem

What is cleartype: http://www.microsoft.com/typography/ClearTypeInfo.mspx

Why is better than standard antialiashing WinXP http://www.microsoft.com/typography/cleartype/tuner/step1.aspx
Win7 http://www.howtogeek.com/howto/28790/

And yes it works on CRT fine.

westfw

#3
Dec 08, 2013, 10:09 am Last Edit: Dec 08, 2013, 10:12 am by westfw Reason: 1
Ok, but what is the "bug" you speak of?  Simply that you think the IDE should use cleartype, but it doesn't?

(so: it's not getting fixed, because no one has reported a bug? 

There is https://github.com/arduino/Arduino/issues/154
and https://github.com/arduino/Arduino/issues/232 )

smilem

The menus are all blank, the program is not usable with Creartype enable, and without I can't use my PC because of poor  readability of text. This is on both Arduino IDE versions.

westfw

Ah; more debugging will be necessary.  It works fine for me with cleartype enabled, on XP, W7, and 8.1, and it's not a problem that anyone else has reported, so it seems to be something particular to your system.  You mentioned that you've been trying to manually edit preferences and themes; does it work better if you clear out all those files and start with a fresh install of Arduino?
(some of the files you'll have to delete manually, I think.)

I don't think anyone will claim that the arduino font and color choices are the most wonderful of all possible, but it should be better than "completely blank" and "unreadable."

smilem

Quote
does it work better if you clear out all those files and start with a fresh install of Arduino?


No, it was like this from the start.

Quote
I don't think anyone will claim that the arduino font and color choices are the most wonderful of all possible, but it should be better than "completely blank" and "unreadable."


yes the menus are white, blank, empty.

smilem

I downloaded v1.5.8 latest, the cleartype bug is still there, win xp32 bit sp3 here.



smilem

I haven't got WinXP any more so I can't try this out but is the info in this link any help?
http://www.gnostice.com/nl_article.asp?id=189&t=Is_ClearType_Enabled_On_Your_Windows_XP_Desktop

Pete
Well yes I know that disabling cleartype will make the arduino IDE work. However this makes text hard to read. So I do not think this is a proper way to solve this, no other Java app has this bug on winxp (at least that I use).

I now use UECIDE as alternative to arduino IDE. But I would like to use official version too. If somebody would debug this .

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy