Go Down

Topic: Iteadstudio TFT ( http://goo.gl/Yb1SeL ) is showing white screen. (Read 1 time) previous topic - next topic


Board Used: Arduino Mega 2560 R3

TFT screen used : http://www.digibay.in/display/lcd/235-3-2-inches-wide-tft-lcd-module-400x240-with-sd-card-slot-and-touch-panel

Library used : UTFT ( http://www.henningkarlsen.com/electronics/library.php?id=51 )

Connections made: http://www.henningkarlsen.com/electronics/files/UTFT_Requirements.pdf

Under this condition (NO uploaded code ) :TFT screen is showing a white screen.

After upload of the code (ATTACHMENT) :
TFT screen is flicking with black and white at DEFINITE intervals. ( as if the code is actually running)

I have made connections twice thinking it  is a connection fault.


I had a similar issue using the ITEAD STUDIO 2.4" TFT based on the ITDB24E.  I issued an lcdOff() and lcdOn() method at the beginning which resolved my specific problem.


Arduino Mega 2560 uses 5V TTL logic. Your display needs 3.3V TTL logic. You must add the level converter to your circuit. Google says:
Arduino Uno R3, Arduino Mega 2560 R3, Ethermega (R3), and some Ethernet Shields (R3), Chronodots, TMP36 sensors, DS18B20 sensors, LCDs/TFTs, RS232C to learn and play...


As mentioned, are you using one of these shields?

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131