Pages: [1]   Go Down
Author Topic: Can Arduino Due libraries be used on Atmel Studio?  (Read 755 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 1
Posts: 103
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

For Atmega328 and Atmega2560, there are successful attempts to use the Arduino libraries in Atmel Studio. You can find them on Google However, this seems not to have been done for Arduino Due.

Can Arduino Due libraries be used on Atmel Studio like atmega328 and atmega2560?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 36
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The current Atmel studio references all board layouts relative to the Arduino library. If you do not have the Arduino development software installed, The Atmel studio Will not reference any libraries. You must specify which version of The Arduino I'd you are using.  If you have the current version, Three drop-down combo boxes Will be available to you. the first should be To select which I'd you are using.   Click the drop-down arrow and select configuration manager. A new window will open That has a drop-down list box, Displaying several options as follows, Arduino 1.1.x , Arduino 1.5.x . Select Arduino 1.5.x.  The next line will ask you where the file is located.  Just fill it in.  The Next line will ask for an alternative location. You can leave this line blank. Hit okay.

Now select which version of the Arduino software you are using.

All libraries should now be available and appear in the proper location.

Hope this helps.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 36
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Note: an apparent bug has been found in the current version of Visual micro.
The bug was identified by someone in the visual micro group.
Apparently visual micro has problems when reading libraries using all  capital letters.
I have confirmed the problem When trying to compile the " UTFT.h " library.
Changing the library name to lowercase letters fixed the problem.

Hope this helps someone.

Joe
Logged

Pages: [1]   Go Up
Jump to: