Go Down

Topic: Problem with DigitalReadSerial (Read 5569 times) previous topic - next topic

Why won't it work?
Please refer to File > Examples > 01.Basics > DigitalReadSerial
I wired up my bread board exactly as specified, and down loaded the program.
The serial monitor window is set for 9600, but shows no response.
I know my board is wired correctly because the "Examples, Digital, Button" program uses the same board wiring, and it works perfectly.
Please help.
Thanks!

I had the same issue. I went so far as to simply short pin 2 to 5V, and still couldn't get the serial read to read high. All I get across the serial read is zeros. I'd live if someone could help answer this question. Since I'm just getting started, and have all kinds if ideas if things is live to do with Arduino I feel really discouraged that I can't even get this thing to work with a single simple input when I didn't even write the program code.

retrolefty

Sounds like you two are describing two different symptoms/problems. One is only serial printing zeros the first saying "not response". The first points to a wiring problem or a broken input pin, the second a serial comm problem. Of course the sketch compiles with no errors so the program is not to blame.



Lefty


Sounds like you two are describing two different symptoms/problems. One is only serial printing zeros the first saying "not response". The first points to a wiring problem or a broken input pin, the second a serial comm problem. Of course the sketch compiles with no errors so the program is not to blame.



Lefty

I checked all the other Com ports. They were not reading anything. Only Com 6 had any data on it.

Go Up