Go Down

Topic: Stuck on uploading... (Read 919 times) previous topic - next topic

dalehand

Hello, I'm newbie here.

Months ago I used the Arduino Duemilanove with Atmega328P-PU, it was working perfectly.

Now it gets stuck on uploading.

I've formated my computer with Windows 7 recently, reinstalled arduino software and installed the FTDI drivers.
When I press the reset button, the L led flashes twice and when appears "uploading" on arduino software the L, TX and RX quickly flashes sometimes then stops on the TX light on, so I don't think is a bootload problem.

I tried the versions 1.0.5 and 1.5.5 in 2 different computers(both with Windows 7).

The program I'm testing is a very simple program:

Code: [Select]

void setup() {
  pinMode(13,OUTPUT);
}

void loop() {
  digitalWrite(13,HIGH);
  delay(250);
  digitalWrite(13,LOW);
  delay(250);
}


I'm a newbie on Arduino/eletronics, so I don't have a clue about what's going wrong...

James C4S

Did you change the board selection in the IDE to Duemilanove?
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

dalehand

#2
Jan 26, 2014, 11:43 am Last Edit: Jan 26, 2014, 11:47 am by dalehand Reason: 1
Thank you for your reply James.
I did it: it is on Arduino Duemilanove or diecemila, with ATmega328 but is not working.
My program compiles and freezes on uploading...

James C4S


My program compiles and freezes on uploading...

It freezes or returns an error?
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

dalehand

Well, it keeps saying its uploading and dont show any errors. It stays uploading forever (I left it for 1h and it was still uploading). Only when I remove/reset the arduino it says:
avrdude: stk500_getsync(): not in sync: resp=0x00

dalehand

#5
Jan 26, 2014, 05:41 pm Last Edit: Jan 26, 2014, 06:21 pm by dalehand Reason: 1
Today it appeared one more message for the first time (but it happened only once):

avrdude: ser_send(): write error: sorry no info avail

and this when i removed:

avrdude: stk500_getsync(): not in sync: resp=0x00

processing.app.debug.RunnerException
   at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:129)
   at processing.app.Sketch.upload(Sketch.java:1672)
   at processing.app.Sketch.exportApplet(Sketch.java:1578)
   at processing.app.Sketch.exportApplet(Sketch.java:1550)
   at processing.app.Editor$DefaultExportHandler.run(Editor.java:2399)
   at java.lang.Thread.run(Unknown Source)
Caused by: processing.app.debug.RunnerException: Problema ao carregar para a placa. Veja http://www.arduino.cc/en/Guide/Troubleshooting#upload para sugestões.
   at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:113)
   at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:127)
   ... 5 more

AMPS-N

What kind of peripheral you have been connected   before you getting above error.
For me same issue being raised , this arises 2 reason
1) If the boot loader has been crashed
2)if fat32 driver stopped working. Check whether ur IC is heating up or not.
AMPS

dalehand

Thank you for replying AMPS.

I have no other peripheral conected on my notebook besides arduino. I don't feel anywhere heating on arduino while the eternal uploading...

AMPS-N

Have you tried uploading bootloader using avr programmer.
AMPS

dalehand

No... Could you teach me how to do this, please?

AMPS-N

#10
Jan 27, 2014, 01:03 pm Last Edit: Jan 27, 2014, 01:52 pm by AMPS-N Reason: 1

No... Could you teach me how to do this, please?

It just simple

https://www.sparkfun.com/products/9825
and Burn boot loader .You will get boot loader updated succesfully

If didn't worked then replace atmega IC replace with new one and do above step. Which will work
AMPS

dalehand

Okay, I'll try. Just waiting the programmer arrive :)

dalehand

Well, I had some problems bootloading the arduino

I'm using a Mega 2560 to bootload, using this tutorial:

http://www.instructables.com/id/Burn-Arduino-Bootloader-with-Arduino-MEGA/?lang=pt

But I'm receiving this message:

avrdude: stk500_program_enable(): protocol error, expect=0x14, resp=0x50
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Go Up