Go Down

Topic: cannot upload sketch to UNO R3 - Expected signature for ATMEGA328P is 1E 95 14 (Read 6309 times) previous topic - next topic


Let me state that I am a complete novice trying to use arduino for the very first time.

I have a ATmega328P R3 ATmega16U2 arduino board and the 1.0.1 IDE running on ubuntu 12.04. When I plug the board into my usb the led on pin 13 blinks. I have selected UNO as the 'board' under the 'tools' menu.  I select dev/ttyUSB0 as my port.

When I try to upload a sketch I have problems it says...
"wrong microcontroller found - did you select the correct board from the tools>board menu?" (I did)
"dude: Expected signature for ATMEGA328P is 1E 95 14
         Double check chip, or use -F to override this check"

So can anyone out there help?
how would I check the chip?

In searching on these forums I find lots of people who are trying to 'bootload' onto a chip who get this same message and must edit arvdude.config but I don't think this applies to me - I have the blinking led  on my board which I believe means bootloading is not necessary, it came with it already on.

Any help at all would be appreciated, I don't even really know if the question as I have put it makes sense.


http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design & Assembly work undertaken


just pressing the big upload arrow, not using any special programmers or anything


Is this an official Arduino or a clone from eBay - gumtree etc. ? As it may have a different chip, but nothing we cant get around.
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design & Assembly work undertaken


Thanks for your interest. It is from china via ebay.

I have maybe made a little progress but have come up against another problem!

I looked at the verbose output and noticed that the boards signature and arvdude config expected signature did not match so I changed the signature in arvdude to

"signature      = 0x1e 0x93 0x07;"

then I tried to upload again but now I am getting the error

"avrdude: verification error, first mismatch at byte 0x0040
         0x0c != 0x33
avrdude: verification error; content mismatch"

perhaps you could help now? Should I have changed that signature?


That's the Sig for an atmega8 - can you read the model number from the top of the big black chip.
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design & Assembly work undertaken


just about yes and you seem to be right it says

ATMEGA8A-PU, just above that it says ATMEL 1329


http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design & Assembly work undertaken


thanks again for your help

duemilanove with atmega 8 is not an option on my drop-down.

how about duemilanove with ATMega328?
how about arduino NG or older with ATmega8?


how about arduino NG or older with ATmega8

Sorry - my list of Arduino boards is HUGE . . . .
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design & Assembly work undertaken


I have the same problem. I've contacted my ebay seller for an explanation...


it says ATMEGA8A-PU

That's the most explicity example of an eBay "Arduino" being an outright fraud that I've seen.
I mean, the occasional "lower quality", or "some percentage of the boards don't work", or "doesn't have the right bootloader" can all seem to be "mere errors" of the sort you might expect from a careless company.  But using the older, cheaper, less capable, ATmega8 chip instead of the ATmega328P goes beyond "mistake" and well into "intentional deception."

Please name names/links, leave terrible feedback, and complain to eBay!

(Interestingly, in order to have gotten the "invalid signature" message when you tried to treat is as an Uno, the ATmega8 has to have been loaded with a modified bootloader.  Because the original Atmega8 bootloaders ran at a different speed, and wouldn't respond at all to Uno-speed commands.)


This is where I say "me too".

I'm an experienced PIC user who thought they would like to try Arduino (I like the idea of shields and jumpers instead of breadboarding or soldering everything).

So I bought a Chinese "UNO R3.0" from eBay - it arrives. It has a  ATMEGA8A-PU chip in it (probably cloned).

OK I thought, I'll give it a go. I download the IDE, install it on PC #1 (laptop with Vista Home Basic).
I am immediately disappointed with the feel of the IDE. Opening an example sketch gives me another window and leaves the default one open - very messy. The speed of the IDE is poor - compiling a 5 line program takes far too long; and the drop-down menus are slow to respond. I plug in the UNO and D13 flashes once per second. I set COM16 and "Arduino Uno" then I hit upload, and it immediately compiles (slowly again!) even though I have made no changes to the sketch. Grrrrr. Upload fails ("not in sync"). After going around driver installs for 2 hours It seems like I'm in hell attempting to sort out what drivers to use. I give up on the laptop.

I move to a nice old reliable XP desktop PC #2. IDE installs ok. I plug in the "UNO" - and it seems to think it's a CH340 USB-Serial adapter - OK - let's go with that and setup the COM port in the IDE. I  open "Tools" menu - and I notice my Modem on COM1 clunks briefly. The menu takes about 10 seconds to open. I select  COM16. Now to set the board -  I  open "Tools" menu - and I notice my Modem on COM1 clunks briefly. I select "Arduino NG or older w/ATmega8"
I hit upload - it compiles ok, D13 flickers then reverts to 1-second flashing. "Done uploading" appears, along with error message "not in sync".

So - do I persevere with Arduino? Right now I realise that my Chinese board is not helping matters at all, but the IDE clunkiness is a big BIG disappointment. Looking at various forums it seems I'm not alone in having driver issues.

Thanks to the guys above who have helped with advice.


OK, 12hrs later and I'm getting there....

It turns out that the "Uno" I received uses an ATMEGA8A-PU and a CH340 USB-Serial chip.

So - step one - get the CH340 drivers installed, then try the loopback test - yippee! I'm talking to the board.
Step two - I need a board definition ("Arduino NG with mega8" does not work). I added the following to boards.txt:-


And bingo, sketch uploads ok and serial port monitors the output. I have managed to get it working on both Vista and XP.

I'm still disappointed at areas of the IDE that are clunky, but at least now I can play with my 'duino. :)

Here is the beast - look closely at the photos - it evens shows a Mega8! :-


Cheers all,


Thanks for figuring this out Andy! 

With 1.5.5-r2 i just needed to add the following line to get the IDE to stop complaining about a missing parameter:


Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131