Pages: [1]   Go Down
Author Topic: Proyecto de sensor temperatura y humedad ( Solucionado )  (Read 1724 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola a todos.
Me presento, soy Mario1307 y necesito algo de ayuda con un pequeño proyecto que tengo entre manos. Os comento lo que necesito realizar.
Mediante un sensor de Tª y Hª DTH11/22 ( me da igual cual), necesito ver los valores de esas variables, con una pantalla de LCD, y a su vez enviar mediante WIFI los valores a una computadora.
Si alguien me puedise echar una mano, se lo agradeciria muchisimo. He de decir que soy muy novato en este mundo de Arduino, pero estoy empezando a ver la amplitud de posibilidades y me estoy enganchando a ello.

Un saludo y gracias por todo
« Last Edit: February 17, 2014, 04:02:09 pm by Mario1307 » Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 217
Posts: 13742
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Echa un vistazo a - http://playground.arduino.cc/Main/DHTLib -
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Spain
Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ve paso a paso. Además tendrás que decir con que componentes vas a mandar los datos mediante wifi, si es una shield, etc.

Primero intenta hacer funcionar el sensor de temperatura y humedad y verlo por el puerto de serie, que es relativamente sencillo.

Luego intenta hacer un proyecto para enviar datos por wifi (para ello vas a necesitar un servidor dentro de la misma wifi para recibir las señales). Osea, mini-proyecto para enviar señales desde arduino y mini-proyecto para el servidor.

Luego hay que juntar las dos cosas  smiley-mr-green
Logged

Google knows it...

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Muchas gracias. Voy a emezar a investigar e ire contando a ver que tal se me da. Lo dicho, muchas gracias smiley-grin
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Por el momento, he conseguido introducir la libreria DHT del sensor, he encontrado un codigo ya creado para leer la temperatura y la humedad, pero siempre me da los mismos valores: 0ºC y 0% humedad. Que estoy haciendo mal???? Muchas gracias
Logged

Onda
Offline Offline
Jr. Member
**
Karma: 0
Posts: 91
This is personal...
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

A veces se tienen despistes, y se obvian estos pasos tan básicos, ¿los has comprobado?;
¿A qué pin tienes conectado el sensor?
Creo recordar que en este sensor hay que poner una resistencia pull-up, ¿la has puesto o lleva una ya integrada?

Logged

---
Saludos,
José Chorva
www.pepechorva.com
@pepechorva on twitter

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

He conectado el pin de datos ( que es el del medio de los 3) a la salida digital Nº2. Y el sensor con el trabajo ya me viene con la resistencia integrada. Ya lei que habia que poner una resistencia de entre 5 y 10 K pero este sensor ya la trae integrada. No se que mas mirar. Ya sospecho hasta del cableado.....

Muchas gracias
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 61
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

PSi puedes poner el codigo sera mas facil ayudarte.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Gracias a todos. Lo consegui conectar. Y ya me da la lectura correcta, mi problema era la conexion con los pines del sensor. Segun el Datasheet el pin izquierdo es de Vcc, el del medio de datos y el derecho GND, pues bien, haciendo muchas pruebas, me di cuenta de que el izq es el de datos y el del medio Vcc. De ahi el problema y por eso no me reconocia los valore....No se puede fiar uno de los fabricantes....

Un saludo
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Por cierto, estoy intentando realizar este mismo proyecto con una Arduino Yun y no me reconoce los datos....eso por que puede ser???
Logged

Onda
Offline Offline
Jr. Member
**
Karma: 0
Posts: 91
This is personal...
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

estos chinos… smiley-mr-green

Lo de la Yún ni idea, no la he tocado, ni siquiera he mirado el datasheet de la misma. ¿Alimentas el sensor desde la Yún? ¿son 5V o 3.3V?  Quizá ahí tienes el problema.
Logged

---
Saludos,
José Chorva
www.pepechorva.com
@pepechorva on twitter

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Estaba alimentando con 3,3 V y funciona con 5V...error mio!!!! tantas horas de trabajo ya te ciegan...jejejeje. Muchas gracias. Ya esta funcionando, ahora a ver si puedo realizar la parte dos del proyecto.
Logged

Onda
Offline Offline
Jr. Member
**
Karma: 0
Posts: 91
This is personal...
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

 smiley-mr-green smiley-mr-green smiley-mr-green
Me alegro que lo tengas funcionando!!! Ahora deberías pones [solucionado] en el título del post  smiley-wink
Logged

---
Saludos,
José Chorva
www.pepechorva.com
@pepechorva on twitter

Pages: [1]   Go Up
Jump to: