Pages: [1]   Go Down
Author Topic: java.lang.OutOfMemoryError when loading sketch  (Read 503 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 2
Posts: 22
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut,

after staring the IDE, I get the following error when opening the third sketch:
Code:
Exception in thread "AWT-EventQueue-0" java.lang.OutOfMemoryError: Java heap space
at java.awt.image.DataBufferInt.<init>(Unknown Source)
at java.awt.image.Raster.createPackedRaster(Unknown Source)
at java.awt.image.DirectColorModel.createCompatibleWritableRaster(Unknown Source)
at java.awt.GraphicsConfiguration.createCompatibleImage(Unknown Source)
at edu.mit.blocks.codeblocks.rendering.BlockShapeUtil.getBevelImage(BlockShapeUtil.java:178)
at edu.mit.blocks.renderable.RenderableBlock.updateBuffImg(RenderableBlock.java:1387)
at edu.mit.blocks.renderable.RenderableBlock.<init>(RenderableBlock.java:271)
at edu.mit.blocks.renderable.RenderableBlock.<init>(RenderableBlock.java:186)
at edu.mit.blocks.renderable.FactoryRenderableBlock.<init>(FactoryRenderableBlock.java:40)
at edu.mit.blocks.workspace.PageDrawerLoadingUtils.loadBlockDrawerSets(PageDrawerLoadingUtils.java:236)
at edu.mit.blocks.workspace.Workspace.loadWorkspaceFrom(Workspace.java:849)
at edu.mit.blocks.controller.WorkspaceController.loadFreshWorkspace(WorkspaceController.java:397)
at com.ardublock.core.Context.resetWorksapce(Context.java:109)
at com.ardublock.core.Context.<init>(Context.java:75)
at com.ardublock.core.Context.getContext(Context.java:62)
at com.ardublock.ui.OpenblocksFrame.<init>(OpenblocksFrame.java:71)
at com.ardublock.ui.ArduBlockToolFrame.<init>(ArduBlockToolFrame.java:3)
at com.ardublock.ArduBlockTool.init(ArduBlockTool.java:28)
at processing.app.Editor.addTools(Editor.java:824)
at processing.app.Editor.buildToolsMenu(Editor.java:693)
at processing.app.Editor.buildMenuBar(Editor.java:486)
at processing.app.Editor.<init>(Editor.java:212)
at processing.app.Base.handleOpen(Base.java:846)
at processing.app.Base.handleOpen(Base.java:811)
at processing.app.Base$8.actionPerformed(Base.java:1604)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
This happens on three PCs, always when opening the third sketch, even if all you do is to open three sketches. I tried with arduino IDE 1.0.5 as well as 1.5.5rc2.
I have windows 7 enterprise 64bit or windows 7 home 64bit, jave is version 7U51
I searched the forum as well as the web but only found this error linked to autoformat

Any help is appreciated
Ciao, Mathias
Logged

Offline Offline
Newbie
*
Karma: 2
Posts: 22
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut,

looks like I am the only one with this problem. Well, in case someone is interested in the fix anyway:
I replaced the call to javaw by the call to the installed JRE (7.51) and changed the heap parameters at startup to -Xms128m -Xmx1024m (was -Xms128m -Xmx128m)

Ciao, Mathias
Logged

Near Karlsruhe (Germany)
Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Mathias,

I'm not sure if I am running into a related prob, at least it sounds similar... (error message)
So, WHERE can I find the access to JRE settings? (W7U64)

Cheers,
okdi
smiley-wink
Logged

Smoke is part of any electronics. If you let it escape the electronics is dead!

Near Karlsruhe (Germany)
Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thx for your message,

and yes, you're correct: my issue is not a Java issue. It has been solved, it was a bootloader issue that played "hide and seek" with my windows.  smiley-wink

Cheers
Logged

Smoke is part of any electronics. If you let it escape the electronics is dead!

Pages: [1]   Go Up
Jump to: