Go Down

Topic: Looking for LCD GURU - s6d0139 driver need init tips - 2.6" LCD from ebay (Read 24792 times) previous topic - next topic

luxboy

hi,

I've bought the same screen and i have the same problem. Screen too white. If i connect the RD to 3.3v i have a little  better image but not 100% good.

Anyone have solved the problem? I think is a wiring problem or the MIE of this screen.

AGARZA, did you have yours working fine?

thanks

acharis

I bought the same shield. Original delivered library was written for alpha version arduino. I made some changes in it and in touchscreen library now it is working good. But I have still problem with backlight (brigtness). I will be very happy, if someone come with solution. (Maybe on HW base, I will try it next, if I will have the time)

luxboy

hi,

did you have the card reader working properly? with the library example provided by the seller bitmap i have always errors.

about the image too clear i have make a change on some wirings and now it works with a great image quality.

thanks

Hr_Jensen

Hi.

I also bought the exact same shield, and having some problems getting it up and running.  :~
But following this thread it looks like there is hope after all.
It sounds like you two (Luxboy and acharis) between you have a complete solution for this board.

Luxboy < can you maybe post a schematic of the wiring ?

acharis < can you maybe post the code and libraries you are using ?


Thanks in advance.
Regards Torben.
Regards Torben Jensen.

luxboy

LCD00 ->08
LCD01 ->09
LCD02 ->02
LCD03 ->03
LCD04 ->04
LCD05 ->05
LCD06 ->06
LCD07 ->07

GND->GND
5V->5V
3v3->A0

RD->3v3
WR->A1
RS->A2
CS->A3
RST->A4

that works great for me!

can anyone have the right process/code to make SD reader work?

acharis

Here you are. Libraries could not be final,  I don't test it frequently.
I dont play with SD card, so at this moment it is not working, but at monday the provider promises me new code for current version of arduino, so maybe there will some progress.


acharis

If I am right there is bad wiring on the board  :~
I found two errors:
Pin 1 from SD card  (CS or SS or CD) is not connected to any pin to the arduino.
Pin 3 from SD card has to be connected to the GND, but is connected to the pin 10.

Other pins are OK, but if I wire the board as luxboy, then the 3,3V is not connected right.

Tommorow I will try to make changes on the board and test it.

Hr_Jensen

Hi.


After a long waiting time, I now have received this from the ebay seller of the board:

"Please go to :https://www.dropbox.com
User name is :icsales.elena@gmail.com
Password: file123
There is an file named:2.6 inch lcd."

Have not tested the code out yet, but thought i share the file.


Regards Torben.
Regards Torben Jensen.

acharis


If I am right there is bad wiring on the board  :~
I found two errors:
Pin 1 from SD card  (CS or SS or CD) is not connected to any pin to the arduino.
Pin 3 from SD card has to be connected to the GND, but is connected to the pin 10.

Other pins are OK, but if I wire the board as luxboy, then the 3,3V is not connected right.

Tommorow I will try to make changes on the board and test it.


No success :(

acharis


Hi.


After a long waiting time, I now have received this from the ebay seller of the board:

"Please go to :https://www.dropbox.com
User name is :icsales.elena@gmail.com
Password: file123
There is an file named:2.6 inch lcd."

Have not tested the code out yet, but thought i share the file.


Regards Torben.


This is old library and old version of arduino. You can use mine attached before.

acharis


LCD00 ->08
LCD01 ->09
LCD02 ->02
LCD03 ->03
LCD04 ->04
LCD05 ->05
LCD06 ->06
LCD07 ->07

GND->GND
5V->5V
3v3->A0

RD->3v3
WR->A1
RS->A2
CS->A3
RST->A4

that works great for me!

can anyone have the right process/code to make SD reader work?


I have new finding:
you can connect both RD and 3v3 to A0

mustafacey

I bought these LCDs and try to control 5 pcs of this module with sample codes and libraries in this topic. Thanks for libraries.
3 pcs are workign perfectly, 1 pcs is working with faded colours and the last one has only white screen.
Namely reason of faded colours is not about gamma variables or library, only because of damaged module.


casemod

I am also having issues with this TFT, but mine does NOT report an ID.

Did anyone bought one recently that could share?

andreword

I struggled with this display, then finally I found the data sheet and worked through until I got the display working

I have the 2.8 inch display

The data sheet is at http://www.rockbox.org/wiki/pub/Main/CreativeZENXFi/DS-S6D0139_V0-5_Preliminary.pdf

The offending code sequence is in LCDTFT.cpp which results in the whitewashed colours
0x0002, 0x0700

Comment out the line and try your code again

//    0x0002, 0x0700, //  field 0 b/c waveform xor waveform

I've attached a ZIP file of the TFTLCD library from my Arduino software, which has been modified
And a copy of a test file that should be useable with the library

Anyway, I hope this helps

Andrew

Go Up