Pages: [1]   Go Down
Author Topic: Arduino Uno R3 With Mac OS X 10.9 Mavericks Not Detected/ No Serial USB  (Read 1546 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 1
Posts: 19
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello, I am posting in the hopes of getting some help with arduino.

I have used arduino for about 1.5 years already on 10.8, and had no problems.

However today I tried to use it on Mavericks (10.9.1) and no matter what I do I cannot get the arduino uno to show on the computer.  The IDE ONLY shows the following:

/dev/tty.Bluetooth-Incoming-Port
/dev/cu.Bluetooth-Incoming-Port
/dev/tty.Bluetooth-Modem
/dev/cu.Bluetooth-Modem

Furthermore, I deleted and tried to reinstall arduino following the sites instructions, and nothing prompts me about it being a network device either, nor is it listed in the network panel.

When I plug in with USB, it does power on (green LED is on, and the light near pin 13 blinks when first plugged in then shuts off shortly after).

I have been trying to fix this for 3 hours now with no luck and have tried everything I found online, including disabling the apple driver and installing the latest FTDI drivers.

All help appreciated as this is extremely important.

Thank you.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am trying to confirm a bug that may be related to yours. I'm using Mavericks and FTDI drivers are installed.

My Arduino Nano is getting power from USB and is powered up when booting up the computer. It will not show up in the list of serial devices unless I remove and reconnect the device from the USB port. I think the problem has something to do with the FTDI driver being loaded while the Arduino is still in its boot up sequence, but not sure.

Could you confirm that your device shows up after removing and reconnecting it to USB/power.

I'm hoping there's a way to re-initialize the FTDI driver and recognize the Arduino without having to physically detach and reattach it.




« Last Edit: March 02, 2014, 03:14:04 pm by daveray » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I got the same problem, how did it work out with yours?
what did you do to let it work?

david
Logged

Fort Lauderdale, FL
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6144
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Does the Arduino show up in "System Information" under USB?
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.c

Offline Offline
Newbie
*
Karma: 0
Posts: 18
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Same issue for me. The board does not show up under system information either.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I have the same problem.

I checked the Disk Utility and (In Spanish it calls Informacion del Sistema, I don't know the name in english)I think is  System Profiler. Mac doesn't recognized the USB Wire.
In the DU, you only can see the FTDI, and thats all.

I hope somebody had a answer.

Oscar Espinosa

Pd: I bought the Arduino UNO, first of all y plug in the USB port of the Mac, the Arduino works by 2 days.
The third day, in the evening it just stop working.
Logged

Manchester (England England)
Online Online
Brattain Member
*****
Karma: 634
Posts: 34541
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Just to say that I have no problem using the Arduino with Mavericks, and that includes using the Due, Uno, Galileo, Leonardo and Tiny.
Sorry no insight on how to cure it I just know I have no problem. 
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
I have the same problem and i have mac os 10.9.3
I tested on mac book air and mac book pro without success.
The Arduino receive power through the usb port but i cannot detect and connect to it.
Did you solved the issue ?
thx
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I have the same problem :/
i have mac os 10.9.4
it's very strange because sometimes in my /dev/ ( when i restart, running naked in the street, when i claps three times in my hands )
Arduino is detected... :

/dev/cu.usbserial-xxxxxxxx
/dev/tty.usbserial-xxxxxxxx

but it's very random  smiley-eek-blue

so if any person found a solution please, no ... PLEASE!  Say me u_u ( i will go crazy ! ) smiley-sweat

sorry for my english i'm french smiley
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm having the same problem with the Freeduino v1.22. I only get bluetooth devices under Tools > Port. I tried removing the Mavericks drivers as per these instructions:

    cd /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns
    sudo mv AppleUSBFTDI.kext AppleUSBFTDI.disabled
    sudo touch /System/Library/Extensions

    reboot

After rebooting I tried installing the FTDI drivers as over 9000 people on the Internet said to do: http://www.ftdichip.com/Drivers/VCP.htm.

Despite what some Google result said that this would work, this did not work for me.

Official Arduinos work, unfortunately I teach a workshop with Freeduinos and my students are 95% OS X. I hate Oracle. I hate Apple but I can't tell everyone in my class to run Linux.

This is the error I get from the IDE when the board is plugged in:

Exception in thread "AWT-EventQueue-0" java.lang.IllegalArgumentException: Bounds out of range: -1,76 [128]
   at processing.app.syntax.JEditTextArea.select(JEditTextArea.java:1178)
   at processing.app.syntax.JEditTextArea$MouseHandler.doDoubleClick(JEditTextArea.java:2353)
   at processing.app.syntax.JEditTextArea$MouseHandler.mousePressed(JEditTextArea.java:2305)
   at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:280)
   at java.awt.Component.processMouseEvent(Component.java:6524)
   at javax.swing.JComponent.processMouseEvent(JComponent.java:3321)
   at java.awt.Component.processEvent(Component.java:6292)
   at java.awt.Container.processEvent(Container.java:2234)
   at java.awt.Component.dispatchEventImpl(Component.java:4883)
   at java.awt.Container.dispatchEventImpl(Container.java:2292)
   at java.awt.Component.dispatchEvent(Component.java:4705)
   at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4898)
   at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4530)
   at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4462)
   at java.awt.Container.dispatchEventImpl(Container.java:2278)
   at java.awt.Window.dispatchEventImpl(Window.java:2739)
   at java.awt.Component.dispatchEvent(Component.java:4705)
   at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:746)
   at java.awt.EventQueue.access$400(EventQueue.java:97)
   at java.awt.EventQueue$3.run(EventQueue.java:697)
   at java.awt.EventQueue$3.run(EventQueue.java:691)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
   at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:86)
   at java.awt.EventQueue$4.run(EventQueue.java:719)
   at java.awt.EventQueue$4.run(EventQueue.java:717)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
   at java.awt.EventQueue.dispatchEvent(EventQueue.java:716)
   at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
   at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
   at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
   at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Logged

Pages: [1]   Go Up
Jump to: