Pages: [1]   Go Down
Author Topic: Problema con pulsadores a arduino  (Read 420 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Tengo un pequeño problema con una maquina que estamos creando con arduino mega, tenemos 20 pulsadores que hacen que bajen o suban unos cristales dependiendo del tiempo, el caso es que tenemos un problema grande con los pulsadores de arriba, tenemos 10 pulsadores arriba y 10 abajo, cuando los cristales tienen que subir por alguna razon se paran en cualquier sitio, arduino detecta que el boton ha sido pulsado aunque nadie lo haya pulsado, el cable de los pulsadores de arriba tiene 2,5 metros de largo, los pulsadores de abajo estan bastante cerca y no fallan, esos van al milimetro.

Los pulsadores estan puestos como si fueran un boton normal, con su resistencia de 10k, y cuando es pulsado, esta en HIGH,

Necesito que alguien me eche una manilla si puede o si sabe el porque no funcionan los de arriba, ya que nos estamos volviendo locos smiley-sad-blue. (no es ruido con otros cables, ya lo hemos probado, creemos que es algo de la tension pero no sabemos como solucionarlo)
Ahora no tengo aqui el programa, cuando pueda lo posteo si quereis.
un saludo y gracias
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 15
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola, hasta ahora en los ejemplos que eh visto, veo que usan resistencias de 1k, no de 10k, no se si sera ese el problema :S, tambien seria de ayuda que pasaras el codigo.

Te mando una imagen de uno de los ejemplos de arduino button:


Es un arduino uno pero deberia ser igual la conexion para el Arduino mega.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No se, los ejemplos que hay en la pagina de arduino vienen con resistencias de 10k, creemos que es algo debido a la longitud del cable hasta los pulsadores lejanos, que son unos 2,5 metros, los cercanos que son alrededor de 30 cm funcionan de maravilla. Lo que nos hace falta saber es el porque los que estan lejos, la arduino detecta como si se pulsa el pulsador a veces, no se, es algo raro. si alguien sabe porque se lo agradeceria que me lo digera. ahora no tengo aqui el codigo, en cuanto pueda lo pongo.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 39
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola, yo el tema de las distancias no lo he respetado algunas veces y me han funcionado las cosas (a no ser que sean señales de datos...), por ir descartando que sea por la distancia intenta hacer algo asi:



Ya se que es lo mismo, pero asi el circuito de pusadores puede consumir mas intensidad (no creo que esta sea la solución pero por ir descartando).

Otra pegunta los pulsadores como los alimentas con la tensión que sale desde arduino o desde una tensión externa?

Mas de una ved he visto condensadores cuando se ponenen muchos botones, creo que es para evitar rebotes, pero no se si es por algo más:



Un saludo.
Logged

Pages: [1]   Go Up
Jump to: