Pages: [1]   Go Down
Author Topic: 64 bit Arduino on 64 bit SUSE Linux v11.1  (Read 1012 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've just installed 64bit arduino-0012 on my SUSE Linux v11.1 machine, as per the clear directions given on the Arduino website. Installation went fine and the Arduino IDE runs OK. I can edit, compile, and upload programs to my Arduino Diecimila board, just as I have done previously under 32 bit SUSE/arduino-0011.

However, when I now send a command to the Arduino board via the IDE/USB connection, the IDE shuts down. This didn't happen under the 32 bit installation.

The command is definitely sent correctly before the shutdown/crash occurs.

Any suggestions?
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 65
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Do you get any error messages at all? Bit hard to say what might be happening otherwise.  

Ver
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Ver! Thanks for responding.

Up until now, I was using the IDE via a desktop link, so saw no messages. I've just tried running the IDE directly from within a terminal window and got the following :

"
koh1@MQUADCORE:~/arduino-0012$ ./arduino
Experimental:  JNI_OnLoad called.
Stable Library
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version   = RXTX-2.1-7
RXTX Warning:  Removing stale lock file. /var/lock/LCK..ttyUSB0
#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007effe926eecd, pid=10829, tid=139637604759888
#
# Java VM: OpenJDK 64-Bit Server VM (1.6.0_0-b11 mixed mode linux-amd64)
# Problematic frame:
# C
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 11
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It sounds like an error with RXTX (the Java library that the Arduino IDE uses for serial communication).  I don't really know enough about the internal workings of that library to have any good ideas here.  Maybe they have a place to report bugs?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I haven't solved the problem with 64 bit Arduino crashing under 64 bit SUSE v11.1, but I've got a practical workaround. I simply use VirtualBox to run 32 bit SUSE v11.1 under 64 bit SUSE, and hence the 32 bit Arduino packages.

Both Arduino v0011 and v0012 then work fine according to the setup instructions on the Arduino website.

But note that to get USB virtualisation working, some configuration (hacking?) is needed. This is a problem both for SUSE, see :
<http://forums.opensuse.org/applications/391984-virtualbox.html>
and for Ubuntu, see :
<http://blog.turbulentsky.com/2008/03/virtualbox-usb-proxy-service-on-ubuntu.html>
Ken hough
Logged

Pages: [1]   Go Up
Jump to: