Go Down

Topic: Bug in Arduino 0017 IDE (Read 697 times) previous topic - next topic

goodie2

Hi and thanks for all your work in building the Arduino IDE.

I found a big bug - the hard way.

1. I started Arduino.exe and the IDE opened and showed an empty document, "sketch_nov23a".

2. I clicked on File, Sketchbook and chose the recent project. (there was only one)

3. It loaded up in another Arduino window. I then closed the original sketch_nov23 empty window.

4. I worked on it for three hours and had my sketch running great.

5. I had to close Arduino temporarily to do something else. I closed the window and it asked if I wanted to save changes and I clicked Yes. It then closed down, but my changes WERE NOT SAVED.

6. I restarted Arduino.exe and my sketch was back at the stage it was three hours ago.

I have replicated this fault again. The fault does not happen if I leave the initial blank Arduino window open and then close that one last.

I am running a Windows XP machine with all straightforward options.

It seems as if the blank initial IDE window is a parent of the new window that is loaded and when the parent is closed the child window becomes orphaned.

Anyway, I hope this helps to improve the IDE. If you can't recreate the bug, I can make a screen-video of it and show you.

Cheers,
Goodie2

mowcius

I have had this happen to me once too.

I just have to make sure I remember to use the save button...

It needs to checka to see if it saved before closing, can this be done easily?

Mowcius

bill2009

I've heard of this so I just treat that first window as a launching pad.  There must be an open issue on google code for it - it's a bad bug.

you might want to check the status there and chime in though - i haven't done it.

mellis

This was inherited from Processing - it will be fixed in Arduino 0018 (the update is already in the SVN version).

mowcius

Cool, when's 18 coming out then?  ;)

Mowcius

Go Up