Go Down

Topic: Recommended gcc version. (Read 984 times) previous topic - next topic

Alan Burlison

Dec 14, 2009, 10:29 am Last Edit: Dec 14, 2009, 04:58 pm by alanbur Reason: 1
I've hit what appears to be the same gcc bug that is described in http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1250084886.  A couple of different gcc versions are mentioned in that thread, but I'm wondering which is the latest version that is known to work?  I'm assuming the last version in the 4.3.x series (4.3.4) is the most likely candidate, is that correct?  This is for the Solaris bundle of the Arduino tools.

Thanks.

westfw

The mac environment seems to be shipping with 4.3.2

wayoda

Hi,
latest Ubuntu 9.10 installs 4.3.3

But I think the problems discussed in the thread you refer to were with 4.3.0. I haven't seen any avr-gcc related postings since 4.3.2 became the most commonly  installed version end of last year.

Eberhard
 

Alan Burlison

#3
Dec 14, 2009, 04:57 pm Last Edit: Dec 14, 2009, 04:58 pm by alanbur Reason: 1
Oops - the forum link I originally posted wasn't the correct one, the problem I'm having is described in http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1250084886, and was seen with gcc 4.4.1 [I've fixed the incorrect link in the original post]

Alan Burlison

In case anyone finds this thread: at the time of writing. gcc 4.3.4 works fine, it appears the gcc 4.4.x series just doesn't work properly for AVR.

Go Up