Pages: [1]   Go Down
Author Topic: Possible Mega Hardware Problem?  (Read 833 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm a student at a university in California working on my senior thesis.  I am using two Megas in my project.  Several other engineers are also using Megas in their projects too.

I've been using a a mega I bought a year ago with 12v (7-12v recommended by spec) input through the barrel jack just fine.  I recently bought a new Mega and hooked it up to the 12v source.  Immediately one of what I think is a filter capacitor (the two rectangle components near the barrel jack) exploded.  I have verified that it was all connected properly.  After desoldering the exploded cap, the arduino works just fine.

This exact thing happened to another engineer with her Mega.  Is it possible that there is a bad batch of megas on the loose?  The old revision I have had orange capcitors,  the ones with problems have black capacitors.

Does arduino warranty the boards from defect?

Thanks!
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 197
Posts: 12744
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Where did you purchase the boards?

Could they be clones?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Everyone has purchased theirs through sparkfun.  I'd assume they are real.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 197
Posts: 12744
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


From SparkFun's web site...

Quote
Warranty Information
SparkFun Electronics strives to provide accurate descriptions and high quality merchandise. If you have any problems with your order, please let us know as soon as possible! We will do everything in our power to make it right. Any reports of problems with an order shipped more than 30 days ago cannot be serviced.

Sounds like a solid guarantee to me.  Contact SparkFun.  I suspect they'll exchange the boards.
Logged

CT, USA
Offline Offline
Sr. Member
****
Karma: 3
Posts: 446
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

When you say you connected it with 12V external power. Did you actually measure the voltage of that power source? The reason I am asking is that a lot of cheap power adapters use only a basic bridge and a capacitor and there is no regulation at all. So under minimum load, the voltage could be as high as 18V which would probably be pushing the limits of the capacitors on the board and cause them to fail.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 23
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm pretty sure those input capacitors are rated at 25V. It sounds like a batch of bad capacitors to me. I've exploded a few capacitors, and it's been either from being too old (mostly in tube radios), putting too much voltage across it, or from getting the polarity backwards. If you say it works without the capacitor, then it probably is the capacitor.

Kyle
Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17261
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Just measure the voltage from the power module without being plugged into anything. If it's higher then the max voltage rating of the input caps then that is likely the smoking gun, however a bad batch of caps is also a possiblity.

Lefty

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Last night I replaced an old Duemilanove 168 with a Mega 1280 within 5 seconds the filtercaps went up in smoke and flames. A close inspection revealed that the caps where rated at 16V the board spec says 6 – 20 limit mind you. The mega was powered by a 9V 500 mA wallwart outputting 14.45 V without load. The boards are the Roboduino MEGA made by DFROBOT www.dfrobot.com. These boards are sold by at least two UK vendors on ebay. The boards are very well made boards the price is great and if powered from the USB port they will do fine. But if powered from an external source it has to one that is as low voltage as possible a regulated. I bought 4 of these boards in September of 2009 so there is a possibility that the design error is corrected, but check.

/richard
Logged

Chester, UK
Offline Offline
Sr. Member
****
Karma: 2
Posts: 489
Trying to return the love to none logic level MOSFETS
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

They sent a replacement to me too - wouldn't work on the external power only USB....
Logged

If your system involves lethal voltages/life critical/flamable elements - you probably shouldn't need to ask.
The Arduino != PC.

Pages: [1]   Go Up
Jump to: