Pages: 1 [2] 3 4   Go Down
Author Topic: Make your Arduino USB for only 1 dollar!  (Read 13155 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 6
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@ noob
I find your post confusing. You say you got a 5 wire DKU-5 but then show six lines. Does your cable have VCC, GND, RxD, TxD, DTR (auto-reset) all at the connector with no extra work? If so that's amazing. Usually you have to work a little to get VCC and a lot to get DTR.

@ everybody who has used DKU-5
I was lead to believe by Tim Small's article that the DKU-5 transceiver had to draw power from the phone at 3.3V. Are those you using the DKU-5 having to supply 3.3V to it? Having to supply 3.3V to the cable would complicate things when working with 5V Arduino.
http://buffalo.nas-central.org/index.php/Use_a_Nokia_Serial_Cable_on_an_ARM9_Linkstation

I wrote an article on modifying a CA-42 to have VCC, GND, RxD, TxD, DTR (auto-reset). It was first on uChobby. Now it's on my blog and linked to by Hack A Day. Please leave a positive comment if you find this useful.
http://hackaday.com/2010/02/25/nokia-usb-cable-is-usb-to-serial-in-disguise/#comments

Logged

SF Bay Area (USA)
Offline Offline
Tesla Member
***
Karma: 124
Posts: 6654
Strongly opinionated, but not official!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

(I think your CA-42 post that appeared on uChobby was the first I had heard of this source of cheap USB/Serial converters (I think I had known that they WERE such, but had never noticed that they were cheap via the mass-market, or that they used standard-enough chipsets to be useful without special phone software.)   *I* found it useful, and have since bought about half-a-dozen such cables, aimed at all sorts of serial things that I'd like to talk to with USB-equipped computers.   (Don't be dismayed by the negative comments on hack-a-day; they seem to be mostly complaining about the long lag between your original posting and HaD picking it up, rather than the idea in general.))
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 6
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you for your kind comment. I first learned about using an old cell phone cable as a USB to Serial TTL cable about two years ago. I must say that I didn't come up with this idea and its an idea that is much older than my tutorial. However, I would like to say while this information was well known to a certain type of hacker it certainly wasn't well known to the Arduino community or other more casual electronics hobbyists. I feel this is true because I searched the Web high and low for an FTDI alternative for at least a couple nights before I came across a post that gave me a lead on using the CA-42.

The reason I wrote the article was not to dredge up some old hack and try to take credit for it but to popularize it and make getting into Arduino much cheaper thus making it more accessible to a wider group of people. That's the spirit of Arduino and open hardware after all.
Logged

B0100111001000011, USA
Offline Offline
Edison Member
*
Karma: 0
Posts: 1503
I'm confused.  Wait, maybe not..
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I agree that it is very useful, and also agree that you shouldn't listen to the negative comments on Hackaday.

I used your tutorial to create my USB-Serial cable, and I couldn't have done it otherwise.  Your guide was very thorough and descriptive, while others were incomplete.

smiley
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 6
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That's very nice of you to say. Thank you.

@ everybody that finds my article useful
Please tell others. Also if you find an error in the article or have a unique experience with hacking your cable please post a comment on my blog.
Logged

Sao Paulo - Brazil
Offline Offline
Sr. Member
****
Karma: 0
Posts: 268
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

hi there!
I'm really anxious about try this idea! Here is very hard to find ftdi chips and also they cost a lot, another problem is soldering smd and find a breakout, so you'll spend a lot to build your own ftdi conververt.
but one question, has anyone tried this cable on Linux? is there any driver?  I'll try it as soon as possible!
Logged

SF Bay Area (USA)
Offline Offline
Tesla Member
***
Karma: 124
Posts: 6654
Strongly opinionated, but not official!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
has anyone tried this cable on Linux? is there any driver?
The "Prolific" chipset used on the CA-42 is one of the most popular USB/Serial converters in the consumer space, and it's well supported by most operating systems (it even worked fine on my Mac.)  But I've had troubles with the DKU-5 that some other people have mentioned.  Some of those seem to have the TI chipset, and it is NOT well supported except by windows :-(
Logged

Bristol, UK
Offline Offline
Edison Member
*
Karma: 1
Posts: 1197
Exhibitor at UK Maker Faire
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I've done this with a CA-42 cable that I got from Deal Extreme:

http://www.dealextreme.com/details.dx/sku.446

It worked fine with Linux, MacOS X and Windows (Windows needed a driver installed). It shows up as a USB serial port in Linux, as expected. I used a TO-92 size 3.3V regulator to supply power to the CA-42 from a 5V AVR development board.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I used a TO-92 size 3.3V regulator to supply power to the CA-42 from a 5V AVR development board.
Huh?  You have to supply the CA-42 cable with 3.3 volts?
Logged

Bristol, UK
Offline Offline
Edison Member
*
Karma: 1
Posts: 1197
Exhibitor at UK Maker Faire
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
You have to supply the CA-42 cable with 3.3 volts?

Yes, according to those web pages that document the method, and the Prolific chip's data sheet. It's surprising, but the Prolific chip is not powered from the USB port, but from the phone (in the original setup).
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Which web pages, please?  All of the CA-42 pages I've looked at suggest the Prolific chip is powered from USB port.  I only came across a couple pages that said otherwise but they were describing the DKU-5 cable.  For example, here's an excerpt from this page; http://buffalo.nas-central.org/index.php/Use_a_Nokia_Serial_Cable_on_an_ARM9_Linkstation.

Quote
pin 4 (sticks out a bit further)+3.3v this is used to power the transceiver on the DKU-5 cable I have (red), but not the CA-42

« Last Edit: March 26, 2010, 12:36:30 pm by Mike-K8LH » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey Guys,

May I ask if the CA-42 cable starts up ok with nothing connected at the Phone end of the cable?  

I just received my CA-42 yesterday ($2.68 from China) and installed the PL-2303 drivers from the Prolific web site on an XP-Pro SP3 laptop and on a Vista Home laptop but after the device drivers are matched up and installed after plugging in the CA-42 both laptops report the same "Unable to start (Code 10)" error.  I'm thinking I have a defective cable.
Logged

SF Bay Area (USA)
Offline Offline
Tesla Member
***
Karma: 124
Posts: 6654
Strongly opinionated, but not official!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
May I ask if the CA-42 cable starts up ok with nothing connected at the Phone end of the cable?  
I have two varieties, and they both show up with nothing connected on the phone end.
One is from ebay seller "topvshonw" and the other from ebay seller "mehonblue"
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you Sir.  I'm going to assume I've got a bad cable.  It'll be interesting to see if Chinese seller will replace this $2.68 item.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I just received a replacement CA-42 cable from the Chinese vendor today but I have the same "Cannot Start (Code 10)" error on the XP-SP3 laptop (PL-2303 driver 2.0.13.130) and on the Vista laptop (PL-2303 driver 3.3.10.140).

Is it possible I'm using the wrong drivers or could I have another problem?

Thanks in advance guys.   Mike McLaren, K8LH
Logged

Pages: 1 [2] 3 4   Go Up
Jump to: