Go Down

Topic: Arduino Duemilanove with Ethernet Shield Problem (Read 8844 times) previous topic - next topic



The problem is that when I connect arduino/ethernet shield, with an external voltage source I have to press reset button to make it work. But when I use it with the USB source everything works fine.

What can be happening? How can I solve this problem?



Feb 18, 2010, 08:21 am Last Edit: Feb 18, 2010, 08:24 am by stephen_t Reason: 1
Common problem, I just live with it, but there are solutions involving seperating out the reset pin on the shield and hooking it up to a digital pin on the arduino and then using code to reset the ethernet after a suitable delay.   Heres an established thread with various suggested solutions :



I have the same problem. In this thread they suggeted to add a Cap from Reset to Ground. http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1225354009/30

But if the Cap is to big the USB based reset will not work. Then you will have to press the reset to perform programming.

in other words : Ethernet Shield succs  :'(

There seems to be a design problem on the Ethernet Shield. But i can not figure it out.


Same problem here.

I scratched off the reset pin line which goes to Ethernet-controller and hooked one digital output from arduino to that pin. Then I can reset the ethernet controller from code when Arduino boots up.


Is there a member of the development team how can look at that problem? Because not every shield seems to have that problem it looks like a timing or race condition problem. may be there is a possibility to perform the reset by library extensions? Is it possible to reset the interfacing chip by software and even resetting the W5100 by software?


Hi all,
i've the same problem.

Are the unofficial (XPort / Wiznet) ethernet module affected by the same problem?
If not, i'll start using the unofficial one...


Hey guys im using the DFrobot Duemilanove and Ethernet shield both  Arduino compatible.
I have the same issue with the Ethernet Shield, i have to reset the board manually every time like reported here otherwise the program seems to freeze when it tries to open a connection to the world.

I have noticed that the problem does not exist when a serial connection is made to the board.

I'm just living with it but might attempt this workaround.



I have an ethernet shield I got off ebay that's based on the ENC28J60 chip and I do not have any issues with it locking up. I scripted to pull from the ethernet shield once every .2 seconds and let it run for a day and a half. Over 200,000 requests and it was solid the whole time.


Scott, you're lucky - my ENC28J60 based unit is a complete bag of nails. I've just bought a WIZ based one (Seeduino) so hopefully it's up to the task...



It's not to do with the design of the ethernet shield but the design of the w5100 ethernet controller chip.

I have a wiz810mj module and can confirm that is also has the same problem.

Looking at the datasheet for the 810 you'll see:
'Reset : This pin is active low input to initialize or re-initialize W5100.
By asserting this pin low for at least 2us, all internal registers will be re-initialized to their default states.'

So, basically, the w5100 doesn't have a 'power-on reset' function. While breadboard testing I've overcome the problem by tying the reset line to the Arduinos reset.

Moving the design off of breadboard will give me the same problem though as the line must 'actively' be pulled low. I'm just going to have to use a digital pin for this I guess. Seems like a waste, but what can you do?

The Cageybee


These problems are fixed in the updated version of the Ethernet shield, which adds a reset controller to reset the W5100 chip on power up.


I bought an ethernet shield at Adafruit just 2weeks ago. How can I tell whether it has got the reset chip?


Does it have a Mini SD card slot?  If so, it's the updated shield that also has the reset controller.


Just purchased a new Ethernet shield from Sparkfun, has the microSD connector, assume is the 05 version. Have it on an Mega2560. Have the sdfatlib20101010 version, just downloaded yesterday.

I am trying to run the SDFatInfo file included in the download.
Am using the recommended SanDisk card, 2MB.
I am getting this error from a card formatted with the SDformater:
card.init failed
SD error
errorCode: 1
errorData: FF

and this error when formatted with Windows 7 format:
card.init failed
SD error
errorCode: 1
errorData: 0

Since the code does not use the Ethernet, I inserted this code to deselect the W5100, and make sure that the SS pin was enabled as output.

 uint8_t r = card.init(SPI_HALF_SPEED,4);

Have tried every combination of input/output , HIGH/LOW on the pins, tried every speed all the way from 0 to 6. Even tried setting it up as software SPI, all with the same results.

I also have several other generic cards i have tried. I know those cards will work when using resistor voltage dividers as on this new Ethernet board, since i have been using these cards on an SD card interface on a PIC board, and they work fine using either hardware or software SPI there.

I have even verified the pins on the eagle schematic vs the Atmel data sheet.

Any one else had experience with this combination?

Go Up