Go Down

Topic: FTDI .inf file for WM5+ Host (Read 2934 times) previous topic - next topic


Is it possible for a new .inf file to be concocted to connect a Windows Mobile 5 upwards device to the Arduino USB to enable at least serial communication between them?

I downloaded the required ARM driver http://www.ftdichip.com/Drivers/VCP/WinCE/CE4252/ARMv4VCPDriver.zip and modified the .inf file with the correct (I hope) idVendor and idProduct which I got using USBView on the main PC. The result was that all seemed OK except that in the Port information on the WM5 device it gave the correct IDs but said no device connected. Other devices work OK.
The .inf file provided with Arduino Uno for PC has quite a lot more in it.

Can anybody help please?
If I am in the wrong forum please tell me.


The uno doesn't have the ftdi chip. So what kind of arduino do you have that you are trying to connect?


Oct 27, 2010, 02:38 pm Last Edit: Oct 27, 2010, 02:40 pm by donone Reason: 1
Ah! Well I'm using a Uno and also a 1280 Mega.
The Uno has a driver .inf file in the driver folder and I thought the Uno had an FTDI chip specifically programmed to look like a serial port.
I am obviously mistaken.

Presumably the Mega has the required FTDI chip for this to work.
Both Uno and the Mega give the same result.
Because you have said what you have, can you move me forward at least another step please. I need to plug the Arduino into the PPC and have the PPC create a virtual serial port so that I can pass data back and forth.

I have a host USB and Standard USB on the PPC.
Anything you can add would be a blessing.


Think you need the host port i.e it needs to be an USB master slot.
For the uno on "normal" Windows you don't realy need a driver just an inf file which driver to use for the connected device.

Did you install the ftdi driver on you WM system and then changed the inf file?


Oct 28, 2010, 03:14 pm Last Edit: Oct 28, 2010, 04:05 pm by donone Reason: 1
Thanks for your reply.
The WM5 (Acer n310) device does have a USB Host.
I downloaded the FTDI driver from their website and followed their instructions. Edited the inf file to the correct ID etc. then...

copied the driver and inf file to WM5 Windows folder.
Plug in the Arduino (tried Uno and 1280 Mega) and a dialog asks which driver.
I type the driver name (ftdi_ser.dll) as instructed.
That was accepted.

No serial port is created but the USB Host info in System Info gives the correct IDs and says no device connected, with both Arduinos.

I checked the registry entries as per...
The only missing is as follows, all others were correct but used "COM" instead of "SER" but I tried both anyway.

Go Up