Pages: [1]   Go Down
Author Topic: USB ports dont work after uno install on win7  (Read 1063 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi there,

Man, this is a serious issue.
I just installed the new UNO on my windows 7. You know, I installed the ArduinoUNO.inf. And for some reason it now fails to recognize my mouse, my external HD,..
The arduino works fine, but the rest...

It still powers it but fails to connect to it.

Does anyone have a clue what to do?
Thanks in advance!
p
« Last Edit: November 26, 2010, 04:05:30 am by Patrizio » Logged

Lancashire, UK
Offline Offline
Edison Member
*
Karma: 8
Posts: 1992
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Shut it down, deprive it of power (pull the plug from the wall and remove the battery if its a laptop), put it together again and restart it.
Logged


0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Worked like a charm!
Thanks man!
Any chance you know why it needed to be deprived of power? or is it just a windows thing?
Logged

Lancashire, UK
Offline Offline
Edison Member
*
Karma: 8
Posts: 1992
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

What happens is that things like USB ports are often 'alive' when the PC is shut down.  Sometimes they crash and because they remain powered  they stay in the crashed state and the operating system can't communicate with them.  They don't have any option but to shut down when you deprive them of power.  25 years in the trade.....  smiley-wink
Logged


0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Allright, I understand.
Thanks again! Next time I have a problem I'll get back at you:)
Logged

Pages: [1]   Go Up
Jump to: