Go Down

Topic: Arduino 021 resets wrong USB (Read 2 times) previous topic - next topic

Checkers1811

Dec 12, 2010, 02:43 pm Last Edit: Dec 12, 2010, 02:45 pm by jahronchek Reason: 1
I have two arduinos plugged into two USB ports (USB4, USB10)

If I select one of them as a target in the pull down menu (USB4)

Then
 both of the connected Arduino boards will be reset when I load to the target.

Shouldn't the Arduino 021 IDE reset only the target board on USB4?

retrolefty

#1
Dec 12, 2010, 04:33 pm Last Edit: Dec 12, 2010, 04:37 pm by retrolefty Reason: 1
Wow thats a new problem symptom. And possibly something never tested for. And yes one would hope the IDE would only reset the selected channel. I would think that it might be a PC driver issue rather then an IDE caused problem and it might be best first to try and determine if this symptom is seen on all three platforms, windows, mac, linux.

Hope you can get some help figuring this one out.  ;)

Lefty

robtillaart


Do you have one or two IDE's ?

If you have two you might simply have to (re)start both of them separately and not use File -> New from the menu. There was another thread lately with a similar error.

What platform do you use?

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

mowcius

I have also had this issue a few times. I have one board connected that I am not actively using but is playing music etc (normally playing music), then I upload and the one playing music will reset and go back to the start of the folder of music it is playing through.

Never had a major problem with it, it's just rather annoying.

Mowcius

zoomkat

I would think that with two IDEs started that the different serial port selection might keep the actions seperated between the boards.
Consider the daffodil. And while you're doing that, I'll be over here, looking through your stuff.   8)

Go Up