Pages: [1]   Go Down
Author Topic: sends dueminlove high when clicking on tools 0021  (Read 2715 times)
0 Members and 1 Guest are viewing this topic.
Michigan
Offline Offline
Newbie
*
Karma: 1
Posts: 33
IR Combat
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Sometimes when I click on the 'tool' menu, my arduino will send all of the digital and analog pins high.  I do not know why it does this, but if I forgot to unplug some of my components, it will fry them because they are designed to pulse through hexfets 10-50ms @ 2Amps, not stay on for 3-5 seconds at 2Amps!

I use windows 7, aruino pro and ardunio dueminlove USB.  This has happened in all prior builds as well.
Logged

IR Combat laser tag developer/inventor

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 362
Posts: 17307
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Sometimes when I click on the 'tool' menu, my arduino will send all of the digital and analog pins high.  I do not know why it does this, but if I forgot to unplug some of my components, it will fry them because they are designed to pulse through hexfets 10-50ms @ 2Amps, not stay on for 3-5 seconds at 2Amps!

Possibly you are resetting the Arduino via the auto-reset feature of the Arduino IDE? If that is it, then all your pins go to input mode, floating. A possible solution for your mosfets turning on in that condition is to wire a pull down resistor between the gates and source terminals. say 10k ohm.

Lefty
« Last Edit: December 17, 2010, 06:58:15 pm by retrolefty » Logged

Fort Lauderdale, FL
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6144
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Sometimes when I click on the 'tool' menu, my arduino will send all of the digital and analog pins high.  I do not know why it does this
Sounds like when the IDE scans for available serial ports, the Auto-Reset goes active.  Follow retro's advice.
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.c

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

The scan routine is very dumb in the original RXTX library. It just tries to open each port. Possible solutions:

1) Go to the FTDI options (Start / Printer and devices) and disable the "port enumeration" (or something similar) and try again

2) Try with a rxtx library mod: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1237179908
Logged

My website: http://ried.cl

Pages: [1]   Go Up
Jump to: